Announcement

Collapse
No announcement yet.

[Request] root and recovery on chinese tablet

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Request] root and recovery on chinese tablet

    Hello, I have a request for modding firmware. Please read from the beginning.

    * wish to get/have:
    1. Root access
    2. Recovery*
    3. Android ICS instead of Android GB

    * device:
    CyberNav Advanced 7" GPS WiFi 8gb 512mb RAM
    Link to the specification:
    http://www.dracotek.com/cybernav-7-i...b-gps70yw.html

    * software provided:
    Firmware sent by seller in .img format
    Link to my dropbox
    http://db.tt/jm7eHfbq
    PhoenixCard tool to burn it on sdcard
    Correct adb/usb drivers installed

    * anything more I can say about it:
    1. It has got only two physical buttons- reset and power.
    2. I tried to enter flash mode but with no result.
    3. Only way to upgrade the firmware is using sdcard.
    4. Chipset is AllWinner A10.
    5. I can use adb if required.
    6. Currently no touch panel- I'm waiting for new one (old one cracked)

    Could someone do this for me please?
    Thanks in advance

  • #2
    I don't have an A10 tablet and am no expert on A10 rooting.

    Ping on snakekiller in the Yarvik tablet forum. Good chance he can help.
    Also check out the guys in the polaroid forum.
    Both of these forums are A10 folks.

    Bob
    "Przebacz im, bo nie wiedzą, co czynią"
    "Прости их, ибо не ведают, что творят"
    "Perdona loro perché non sanno quello che fanno"
    "Vergib ihnen, denn sie wissen nicht, was sie tun"
    "Vergeef hen want ze weten niet wat ze doen"
    "Pardonne-leur car ils ne savent pas ce qu'ils font"
    "Perdónalos porque no saben lo que hacen"
    "Oprosti im, jer ne znaju što čine"
    "Atyám, bocsásd meg nekik, mert nem tudják mit cselekszenek!"
    "Odpusť jim, neboť nevědí, co činí"
    "Πάτερ άφες αυτοίς, ού γάρ οίδασι τί ποιούσι"
    "Ojcze, przebacz im, bo nie wiedzą, co czynią"
    "Forgive them as they know not what they do"

    Comment


    • #3
      Basic Android Terminal and ADB Shell Command List

      1. How to open a cmd in Android PhoneMethod 1: “Start” – “”Program”-” “Accessories” – “” Command Prompt ”
      Method 2: “Start” – “” Run “, type cmd ENTER

      2. How to restart Android Phone/tablet
      When the phone and Computer is connected to the data cable, you can enter the following command

      1
      adb shell reboot === ENTER

      3. Restart Android into Recovery Mode
      With the data cable connected to your phone and computer, enter the following command

      1
      adb shell reboot recovery === ENTER


      13. From the Recovery Screen, send an update file to your SD card.
      1
      2
      3
      adb shell mount /sdcard
      adb shell rm /sdcard/update.zip
      adb push *filename* /sdcard/update.zip

      14. Restoring a nandroid backup via Fastboot
      Start command-prompt/terminal cd to the nandroid folder and enter following commands

      1
      2
      3
      4
      5
      6
      7
      fastboot erase boot
      fastboot erase recovery
      fastboot flash system system.img
      fastboot flash boot boot.img
      fastboot flash userdata data.img
      fastboot flash recovery recovery.img
      fastboot reboot
      Last edited by snakekiller; 05-14-2012, 09:00 PM.
      if you love my work please buy a coffee





      Comment


      • #4
        Thanks mate, update from sdcard works, I mean after burning firmware in phoenixtool and putting sdcard into the tablet it starts updating. So might be kinda script or something in nand.
        Cheers
        _sek

        Update

        If I could have touch recovery that would be awesome. Then I don't care about ICS. But as I already mentioned- my tablet has got only two hardware buttons... I'm going to install it in my car permanently in this place (not finished yet- needs final filling and painting):

        It will take extra time to take it out in case of brick or some kind of malfunction. So I'm going to use made by me usb socket below the central console to send files from laptop:

        That's why I need recovery so much.
        Regards
        _sek
        Last edited by sek; 05-14-2012, 05:42 PM.

        Comment


        • #5
          my tablet go to recovery when i put menu button en holding the power button at the same for about 5-6 sec.

          you have just reset and power right?

          have you try the same like me but with your reset and power button?
          maybe thats works.
          if you love my work please buy a coffee





          Comment


          • #6
            and for root acces just use gingerbreak
            thats a apk .
            just install it and open it.
            thats works for android 2.2 or 2.3
            if you love my work please buy a coffee





            Comment


            • #7
              take a look at the link please
              they took android commander for rebooting the tablet too recovery
              http://pulsepc.ru/itnews/instrukciya-po-vosstanovleniyu-avtonavigatora-cybernav-gps-android-2.2.html
              Last edited by snakekiller; 05-15-2012, 12:54 PM.
              if you love my work please buy a coffee





              Comment


              • #8
                Thank you so much for your helpful answers! I'll try everything you wrote about tomorrow, I'm quite busy at work and have 3 months old baby so I don't have much time during my shift. Will report the results. Thanks again
                Regards
                _sek

                Comment


                • #9
                  I checked adb commands- adb shell reboot recovery and it doesn't work. Reboot to recovery option in Android Commander doesn't work also. I tried enter recovery by pressing on/off button and reset button at the same time and still nothing.

                  Up

                  I'll pull recovery img if it exist :what: and maybe you can find what is the problem.
                  Last edited by sek; 05-16-2012, 05:15 PM.

                  Comment


                  • #10
                    Didn't do this yet but I found some info that this tablet has got locked bootloader, that's why can't be turned on into recovery. Do you think it's true?

                    Comment


                    • #11
                      i downloaded your rom and try it on my tablet with livesuit and its works with livesuit.
                      sow the img is compatible with livesuit and your flastool.

                      Verstuurd van mijn GT-S5660 met Tapatalk
                      if you love my work please buy a coffee





                      Comment


                      • #12
                        So I as far I know .img firmware file can be decompressed (?) with an application image burner for windows. Then I have .fex and .hdr files from it. On Linux these can be changed to boot.img, system.img etc. Is there any chance to modify the bootloader.img to get recovery working- if bootloader is locked? If not, only option for me, is to keep .img files as an emergency recovery...
                        Last edited by sek; 05-22-2012, 04:37 AM.

                        Comment


                        • #13
                          Please help me

                          Hello! Sorry for my english (Google Translator). I have the same problem. When connecting to the PC, reboot and now it is always in a state that is android logo then the system will not boot.
                          The device according to the filling is not very different from Sek's device:
                          Model Name: GPS70YW
                          GPS chip: SiRF Star IV
                          CPU: infoTmic ARM11 1GHz
                          RAM: 256MB DDR2
                          Internal memory: 4 GB
                          WIFI: 802.11 b/g/n

                          Infomation from android commander:
                          Model: PW08
                          Device: crane-pw08
                          Brand: softwinners
                          Manufacturer: unknown
                          Baseband: unknown
                          Bootloader: unknown
                          Release: 2.3.4
                          Build ID: crane_pw08-eng 2.3.4 GRJ22 eng.yf.r1-139-gb15c860 test-keys
                          Root access: available
                          BusyBox: v1.18.3

                          I assumed that the firmware from Sek suitable for my device, but unfortunately, after flashing the situation has not changed. Other firmware unfortunately could not be found, so I write here. Guys, help me find the right firmware. Thanks in advance.

                          Comment


                          • #14
                            Lucky I believe I know how to fix your problem. Will post later because I'm away from home.
                            Just check do you have access to your tablet using adb
                            adb devices

                            Comment


                            • #15
                              Sek, I have climbed all the internet and tried many variants, including the visit to your topic on the site xda (http://forum.xda-developers.com/show....php?t=1643163), but the situation has not changed. I think in my case will help me only original firmware. And yes, the adb identifies the device

                              Comment

                              Working...
                              X