Announcement

Collapse

BEELINK AP34 ULTIMATE FREAKTAB GIVEAWAY


Yet Time for an nother Big Giveaway!
This thime with 3 BEELINK AP34 ULTIMATE.
Got here to Enter the Game:
http://freaktab.com/forum/main-categ...aktab-giveaway
See more
See less

Unofficial TWRP 2.7.0.0 for Rockchip's

Collapse
This is a sticky topic.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by abdul_pt View Post

    Let's start over.
    Please test this image, this is stock recovery that i have. Please confirm that it works.
    http://www.freak-tab.de/abdul_pt/TWR...ry_MK908II.img

    If it works, flash TWRP again and boot it. If you have ADB connection grab recovery.log/dmesg.
    Code:
    adb shell dmesg > dmesg.txt
    adb pull tmp/recovery.log
    And send them to me.

    If it doesn't work, i need a working stock recovery.
    just had another go, your stock recovery displays a pic of an android on its back with "no command" on the screen - no options, reboots system if left . Have re flashed twrp and tried to boot but stuck on splash screen - not shown up on pc as adb device or anything else when stuck on Teamwin splash. Adb is working when the stick boots normaly and i have a dmesg but the recovery.log was not found.
    Attached Files

    Comment


    • Can you test this image, please - http://www.freak-tab.de/abdul_pt/TWR...K_SDcard_L.img

      Make sure that you have flashed a kernel.img to the kernel partition because this is just the ramdisk.

      If it hangs and you still can't get recovery.log, reboot to Android and check /cache/recovery for any log's and share them.
      if [ $up.post.type = $type.two.lazy.to_use_google ] || [ $up.post.type = $type.silly_question ];
      then mv $user.contact.up.post /.trash; set response($response.type = ignore);
      $user.up.post.ignore_in_future = true; fi;

      Comment


      • Originally posted by abdul_pt View Post
        Can you test this image, please - http://www.freak-tab.de/abdul_pt/TWR...K_SDcard_L.img

        Make sure that you have flashed a kernel.img to the kernel partition because this is just the ramdisk.

        If it hangs and you still can't get recovery.log, reboot to Android and check /cache/recovery for any log's and share them.
        Still hangs on teamwin splash, nothing written to /cache/recovery. flashed reccovery to address as per parameter file with rom 0x00010000@0x00010000 but noticed it is different in dmesg -

        2.090631] mmcblk0: mmc0:b368 NCard 7.21 GiB
        <6>[ 2.095905] misc: 0x000400000 -- 0x000800000 (4 MB)
        <6>[ 2.095947] kernel: 0x000800000 -- 0x001400000 (12 MB)
        <6>[ 2.095995] boot: 0x001400000 -- 0x002000000 (12 MB)
        <6>[ 2.096033] recovery: 0x002000000 -- 0x004000000 (32 MB)
        <6>[ 2.096071] backup: 0x004000000 -- 0x008000000 (64 MB)
        <6>[ 2.096109] cache: 0x008000000 -- 0x010000000 (128 MB)
        <6>[ 2.096148] userdata: 0x010000000 -- 0x110000000 (4096 MB)
        <6>[ 2.096187] metadata: 0x110000000 -- 0x110400000 (4 MB)
        <6>[ 2.096224] kpanic: 0x110400000 -- 0x110800000 (4 MB)
        <6>[ 2.096262] system: 0x110800000 -- 0x140800000 (768 MB)
        <6>[ 2.096301] user: 0x140800000 -- 0x1cdd00000 (2261 MB)
        <6>[ 2.096347] mmcblk0: p1 p2 p3 p4 p5 p6 p7 p8 p9 p10 p11
        <6>[ 2.142850]

        FIRMWARE_VER:4.4.2
        MACHINE_MODEL:rk30sdk
        MACHINE_ID:007
        MANUFACTURER:RK30SDK
        MAGIC: 0x5041524B
        ATAG: 0x60000800
        MACHINE: 3066
        CHECK_MASK: 0x80
        KERNEL_IMG: 0x60408000
        #RECOVER_KEY: 1,1,0,20,0
        CMDLINE:console=ttyFIQ0 androidboot.console=ttyFIQ0 init=/init initrd=0x62000000,0x00800000 mtdparts=rk29xxnand:0x00002000@0x00002000(misc),0x 00006000@0x00004000(kernel),0x00006000@0x0000a000( boot),0x00010000@0x00010000(recovery),0x00020000@0 x00020000(backup),0x00040000@0x00040000(cache),0x0 0800000@0x00080000(userdata),0x00002000@0x00880000 (metadata),0x00002000@0x00882000(kpanic),0x0018000 0@0x00884000(system),-@0x00A04000(user)

        Comment


        • This is getting on my nerves. Let me download the ROM and have a look at it.

          I also currently don't have any rk box to test this images, so bare with me.
          if [ $up.post.type = $type.two.lazy.to_use_google ] || [ $up.post.type = $type.silly_question ];
          then mv $user.contact.up.post /.trash; set response($response.type = ignore);
          $user.up.post.ignore_in_future = true; fi;

          Comment


          • It seems to be a kitkat problem, I had twrp working a while ago with this stick running a jb ROM but since being on kk have not managed to get twrp to boot,

            Comment


            • Hi abdul_pt,

              You did some great work here. Thanks in advance.

              I just got an 8" tablet 1024x600 by proscan running rk2928. I would love to put TWRP on it. So far CWM worked but I couldn't use it because the tablet only comes with a power button. OTG didn't work for me here.

              I tried to flash the TWRP flash IMG using batch tool but it bootlooped.

              IF you have time could you help me make a custom recovery for this tablet?

              The full firmware is linked here.

              http://www.curtisint.com/html/CustSe...B_FIRMWARE.ZIP

              Thanks.

              K

              Comment


              • Hi abdul_pt,
                Much time has passed since you helped me with my problem, and suddenly I noticed that TWRP no backup partition system . I am sorry for what I have so much time had not noticed, I'm probably blind (
                I am attaching the log, please see it, it may be only a small correction is necessary twrp.fstab...
                Attached Files

                Comment


                • Originally posted by marko33 View Post
                  It seems to be a kitkat problem, I had twrp working a while ago with this stick running a jb ROM but since being on kk have not managed to get twrp to boot,
                  Been absent for a while, but i'm always here reading.

                  Please test and report back. Be sure to have a valid kernel in kernel partition.
                  http://www.freak-tab.de/abdul_pt/TWR...RP_Marko33.img
                  if [ $up.post.type = $type.two.lazy.to_use_google ] || [ $up.post.type = $type.silly_question ];
                  then mv $user.contact.up.post /.trash; set response($response.type = ignore);
                  $user.up.post.ignore_in_future = true; fi;

                  Comment


                  • Originally posted by zerocold1981 View Post
                    Hi abdul_pt,
                    Much time has passed since you helped me with my problem, and suddenly I noticed that TWRP no backup partition system . I am sorry for what I have so much time had not noticed, I'm probably blind (
                    I am attaching the log, please see it, it may be only a small correction is necessary twrp.fstab...
                    [ATTACH]temp_10710_1434649046178_395[/ATTACH]
                    TWRP doesn't play well with non EXT4 FS, at least this has been my experience so far
                    Code:
                    /system | /dev/block/mtdblock9 | Size: 639MB Used: 317MB Free: 321MB Backup Size: 317MB
                       Flags: Can_Be_Mounted Can_Be_Wiped Can_Be_Backed_Up Wipe_Available_in_GUI IsPresent
                       Primary_Block_Device: /dev/block/mtdblock9
                       Display_Name: System
                       Storage_Name: System
                       Backup_Path: /system
                       Backup_Name: system
                       Backup_Display_Name: System
                       Storage_Path: /system
                       Current_File_System: ext2
                       Fstab_File_System: ext4
                       Backup_Method: files
                    You would do better by changing system FS type.
                    if [ $up.post.type = $type.two.lazy.to_use_google ] || [ $up.post.type = $type.silly_question ];
                    then mv $user.contact.up.post /.trash; set response($response.type = ignore);
                    $user.up.post.ignore_in_future = true; fi;

                    Comment


                    • Originally posted by RealGM View Post
                      Hi abdul_pt,

                      You did some great work here. Thanks in advance.

                      I just got an 8" tablet 1024x600 by proscan running rk2928. I would love to put TWRP on it. So far CWM worked but I couldn't use it because the tablet only comes with a power button. OTG didn't work for me here.

                      I tried to flash the TWRP flash IMG using batch tool but it bootlooped.

                      IF you have time could you help me make a custom recovery for this tablet?

                      The full firmware is linked here.

                      http://www.curtisint.com/html/CustSe...B_FIRMWARE.ZIP

                      Thanks.

                      K
                      Please test and report back
                      http://www.freak-tab.de/abdul_pt/TWR...LT8015-K-B.img
                      if [ $up.post.type = $type.two.lazy.to_use_google ] || [ $up.post.type = $type.silly_question ];
                      then mv $user.contact.up.post /.trash; set response($response.type = ignore);
                      $user.up.post.ignore_in_future = true; fi;

                      Comment


                      • Originally posted by abdul_pt View Post
                        You would do better by changing system FS type.
                        Thank you very much for the advice ) I tried a different operating system , and faced now understand why not noticed this problem was not in the previous operating system. Once again thank you for your work , you are the best

                        Comment


                        • Originally posted by abdul_pt View Post

                          Hi Abdul_pt,

                          That works great!!

                          Thanks so much. you are a genius!

                          Comment


                          • Originally posted by abdul_pt View Post

                            Been absent for a while, but i'm always here reading.

                            Please test and report back. Be sure to have a valid kernel in kernel partition.
                            http://www.freak-tab.de/abdul_pt/TWR...RP_Marko33.img
                            just tried image, unfortunately does not boot at all, tv displays no signal. no twrp folder created on sd card

                            Comment


                            • Originally posted by RealGM View Post


                              Hi Abdul_pt,

                              That works great!!

                              Thanks so much. you are a genius!
                              NP.
                              Thanks for the feedback
                              if [ $up.post.type = $type.two.lazy.to_use_google ] || [ $up.post.type = $type.silly_question ];
                              then mv $user.contact.up.post /.trash; set response($response.type = ignore);
                              $user.up.post.ignore_in_future = true; fi;

                              Comment


                              • Originally posted by marko33 View Post
                                just tried image, unfortunately does not boot at all, tv displays no signal. no twrp folder created on sd card
                                That image works on my mk902, something is not right.

                                Do you have a kernel in the kernel partition ?
                                if [ $up.post.type = $type.two.lazy.to_use_google ] || [ $up.post.type = $type.silly_question ];
                                then mv $user.contact.up.post /.trash; set response($response.type = ignore);
                                $user.up.post.ignore_in_future = true; fi;

                                Comment

                                Working...
                                X