No announcement yet.

Polaroid PTAB7XC Ice-Cream Sandwich Tablet (Google Play Needed)

  • Filter
  • Time
  • Show
Clear All
new posts

  • Polaroid PTAB7XC Ice-Cream Sandwich Tablet (Google Play Needed)

    Hello, I just bought this nice tablet from Kohls for $99.99 on sale from $129.99, but it doesnt have Google Play just Amazon market which totally kills the tablet so can anyone help me add gogole play to this tablet? It is current running Ice-Cream sandwich 4.03.

    Thank You!


    Capacitive touch screen with 800 x 480 resolution and four-way auto rotation makes navigating simple.
    ARM Cortex A8 1GHz processor, 512 MB DDR3 RAM and Android 4.0 Ice-cream Sandwich operating system offer powerful access to special features and apps.
    Front 0.3 megapixel camera, built-in microphone and 802.11 b/g/n WiFi network let you video chat with family and friends.
    Internal memory holds up to 4GB and the micro SDHC card slot expands memory up to 32GB.
    Mini USB port offers added versatility.
    Rechargeable lithium-ion battery provides hours of use.
    Bookstore accessibility lets you download more than 2 million books, magazines and newspapers.
    3.5-mm headphone jack and built-in speaker allow you to listen to music and audio books in private or aloud.
    Screen: 7 inches
    Model no. PTAB7XC

  • #2
    LOL, are you me? I just posted a thread RIGHT after you evidently..

    I got the same tablet today also, but for 99$ It was on sale, It's a NICE tablet for the money, I have done alot on it already!

    Here are the steps I used for my tablet and it worked!

    I put these on a memory card and used the android file browser to run them...
    I first installed "OneTimeInitializer-signed.apk" successfully, then attempted to install "GoogleServicesFramework-signed.apk" but the installation failed for some reason. I moved on to "SetupWizard.apk", which was successful, and finally "vending-3.1.3-signed.apk", which also was successful.

    This gives me a fully working version of the Android Market (only the Icon is the old Icon, launching actually shows the Google Play interface)

    goodluck, it's easy and takes 2 minutes


    • #3
      Originally posted by diabls View Post
      LOL, are you me? I just posted a thread RIGHT after you evidently..

      I got the same tablet today also, but for 99$ It was on sale, It's a NICE tablet for the money, I have done alot on it already!

      Here are the steps I used for my tablet and it worked!

      I put these on a memory card and used the android file browser to run them...

      goodluck, it's easy and takes 2 minutes

      LOL, I noticed that but I assure you we are two different people. I have one concern you might be able to answer the fix you used included a framework file is that for Ice-Cream or Gingerbread? I dont want to screw anything up as there is no way to restore the system is there??



      • #4
        yea, when I first read your post I thought it was mine, but I saw it was a different name and then realized lol. I'm guessing it's ICS as my tablet is ICS and it worked fine for me and still working great today. Hope that helps


        • #5
          Really Really New...

          Hey everyone,

          I have been reading a lot of the posts on this forum and I have to say I am very excited and impressed by all of your work and efforts to help people out. I am glad to have joined this forum. I am totally new and just bought one of these (PTAB7XC) at Kolhs too and was wondering about adding the full app store of Google. From what I have gathered is that most believe it is similar or same to the PMID702C/PMID703C model in almost every way. I know nothing about "rooting", scripts, .apk files, etc.

          I wondered if I do not have a micro SD card yet (will be getting one soon) should I just wait to do any of this until I do?

          Should I follow the instructions for PMID702C? Which one is the best/newest set to follow to achieve this in the easiest way for such a newbie like me?

          I also have a Mac (for work) as my computer not a PC and will this mess things up?

          Can you have the Amazon App store and Google as well? What about free apps through itunes? Will they only work on iPads and iPhones or will they work on this? Do i have to search an Android version?

          I enjoy the tablet so far, just wanting to take full advantage of it without messing it up because I don't think i could fix it (Flashing and what not).

          Sorry for all the questions but you seem like the people to ask!


          • #6
            If you follow my instructions above to put the google marketplace onto your device, you could do it without the SD card. Atleast it should still work as I don't see any reason that it wouldn't.

            You could hook your tablet to your PC with the USB and when it mounts, you could move the files from the upload above and use the already installed file manager on the tablet after disconnecting the tablet from the pc and follow the instructions and should be set

            Either way, an SD card is a must with all the apps you're gonna wanna have


            • #7
              More Questions...

              Thank you for the recommendation...I will have to try that tonight and see how it goes I guess. I am just really timid that I don't want to mess this up.

              Just to be clear, I do not need any software (for Rooting or anything) to do this. I just download, unzip/unrar the download and then load via USB then use the file manager on the tablet to do what you said (double click I think) and it should work right?

              A few more questions provided that all goes well. Would a 16G Micro SDHC card be what I want at least starting out for size/storage/function? Does Class ratings have a big impact on performance if it is one of the normal name brands?

              What about the App called App 2 SD...will/does that work ok on these and does that really save you some internal space if you have an SD card? Does it work ok with apps but can also use your MicroSD card for Movies, Music, Pics, etc.?

              Any other standard/normal recommendations going forward regarding apps or anything else to optimize my tablet without breaking it?


              • #8
                Doing something this simple, it would take alot to mess anything up, atleast something that couldn't easily be fixed. :P

                I'm kind of in a hurry and saw you replied, so I wanna reply quick before I get back later today.. I found a link from somebody for a 32gb SDHC card on amazon for 21$ Forgive me if links aren't allowed, I will check later ( It hs good reviews so I doubt it's a fake, as on **** many memory cards and usb flash drives are fake sizes.

                **EDIT** well since about 2 days ago, the price has dropped to 19.99$ for the memory card, even better


                • #9
                  I think i did it...I'm trying to do the setup now should i skip 'til later? Should I turn it off and back on or does that matter?!


                  • #10
                    Market works but have an issue or two if you can help...

                    I was able to get market working on my tablet. The problem I have seemed to run into is my home button (on the bottom and looks like the top of a house) is not working. This is also a problem that I cannot seem to leave my browser/apps/etc.

                    Also when my tablet first turns on it asks me after the booting scree to take action with the following two options. It gives me the option of going with Launcher and some other option. I have selected launcher and it seems to come back up to the normal start screen. I have powered down twice and this seems to always come up each time.

                    Not to add to my laundry list but My clock for some reason was way off when I left the "configure clock based on network" option checked. I just set it manually and it seems to be doing ok so far.

                    The big button at the bottom on the center of the plastic frame (not on the screen) also now seems not to work for some reason, it usually takes you back out each time.

                    I am not sure if/how to fix these issues but those are the ones I have ran into in the brief time I worked on it last night. I am very happy to have the market, don't get me wrong. I downloaded Angry Birds just to test and see if it actually worked and it seemed to be just fine.

                    Also do I now delete the files I moved over to install market or leave some/all of them? I have a micro SD card on the way.

                    The only thing I could figure out (after the fact) through reading through a bunch of the other threads was my "debug option via USB" was not turned on when I moved the files over, which I am just trying to learn things without breaking stuff.

                    I am sorry to act like such a Noob, but I really am totally new to this. Any thoughts on my other questions would be appreciated. Sorry and thanks for any and all help.


                    • #11
                      Hey! Every single thing you mentioned in your post, is the same with me. If I can remember what you said as I post this, I'll address it. But before that, everything you said that isn't working, I wasn't sure if it was working before for me or not as the second I turned on my tablet I installed the market place, so I was never sure if the home button worked or not. lol (i'm guessing it did work before since you are noticing it now)

                      My clock never worked right when I used the set by network, I had to manually set it and choose my timezone but ever since then it's stayed correct and the date is also still correct.

                      When you first turn your tablet on and it asks, I always chose the launcher, but it also has a box to check to never ask again or something like that, I chose that so it always boots to the home/main screen

                      Now to leave apps, I usually use the button in the bottom left of the screen that is like a back button, Some apps it will work as an exit button right away, others it will just go back and back until it reaches the first page of the app and then hit back again and it will leave the app (kind of annoying as it takes a few seconds longer to leave an app, but it works.)
                      Some apps have like 3 little dots in the middle of the screen at the bottom menu bar, if u click that it'll bring up a little window that sometimes has EXIT and other info, some apps don't always have an exit, so u gotta use the back button to do it.

                      You can delete the files that you used to install the market place, as I removed them from my SD card after I installed it. (I would just save them on your PC so you'll have them if you ever get another tablet or redo this one.) I have a folder on my PC with all the tablet related files I have/used so I'll always have them in 1 place.

                      If i'd known of these issues after updating to the marketplace, I would have warned you, but I had no idea as I didn't know if the home button worked before I did the marketplace install or not, as I said above I installed the marketplace as soon as I first turned my new tablet on. lol (there may be a fix to this, I haven't looked yet as I sort of figured it may have never worked before)

                      You're fine, I'm surprised there isn't alot more activity in the polaroid section, then there is. Also, alot of the times when I install something major, I'll reboot the tablet before running the new app, it usually shoudln't matter but sometimes it might help to clean up the install with a reboot.
                      Last edited by diabls; 06-19-2012, 07:03.


                      • #12
                        Well at least I feel better with some company...

                        Thank you for getting back to me. I did notice I was able to do the whole back button thing until I got to where I wanted to be but you are right it is annoying.

                        I was reading in the 702C forum that people apparently had the same problem but did a factory reset and then followed another set of instructions and that made it better? I am not sure what a factory reset is. Is it that little hole on the back or does that do something completely different?

                        Some talked of side loading and I am not exactly sure what that is (is it just putting it on an SD card from your computer and then dropping it on the tablet kind of like last night?) so I don't know about that.

                        Please keep me updated on anything you find out. I kind of wonder if there should be at PTAB7XC Thread with all the info/problems/fixes/etc. in it, as I, like you am trying to learn and get up to speed, its fun but its scary too. I have to believe many more people bought these at Kohls and these may be almost the exact same as the 702C just labeled differently for Kohls (I only speculate, don't know for sure), so I would think there are more people out there learning/knowing/doing things to help us out. I do like the community of people willing to help and share here.

                        Thanks for your help and sorry to keep asking for all the help/questions but like I said I am trying to catch up.


                        • #13
                          You're fine man, I'll help as much as much as I can! I do believe the tablets are all the same pretty much, just different model numbers with slightly different hardware setup. IE: camera, no camera, tv out, no tv out...

                          I believe the reset button on the back would be for resetting the tablet if it froze and wasn't responding.. There should be a factory reset in the settings menu, near the bottom of the settings page.


                          • #14
                            Will the factory reset take be back to square one out of the box? If/when I go to add Google Play again will the stuff I put on before be erased (gapps 2.3.4, Angry Birds, etc.)or will it complicate matters? I am tempted to do a factory reset (provided it takes it back to square one) and use Amazon, Mobileone or another free app site until this/these issues gets better and/or figured out. I just really don't want to mess things up but I really want to try things as long as they don't ruin or lessen the tablet and its functionality. I know you have heard this before but just telling you where my head is at I guess. When I get off work tonight I will check back in here and try to figure out how to proceed. Thank you again for all your help and support.

                            As they say, "It ain't easy being green"!


                            • #15
                              I would think the factory reset would take you back to the day you got it, with no google marketplace or anything installed.. From what I'm reading, if you do a factory reset now, reinstall google marketplace hten your home buttons will work. It seems like a weird fix, but that's how I understand it. It's worth a try ifyou're gonna do a factory reset anyways, you could reinstall google marketplace, see if the home buttons work and if they do, good.. If not, then just do another factory reset and setup your tablet how you want until there is maybe a fix to the home buttons after installing google marketplace, then you could install the marketplace, and if you can't get it fixed after tehre's a "fix" then you'd just be back again withoutt he home buttons lol. Not a big loss, but atleast trying if you want to do a factory reset and do some testin.

                              (i'd do a factory reset, but i've added so much stuff to mine in the past few days, I don't feel like redoing all the settings agian right now lol)