Announcement

Collapse
No announcement yet.

Extend your Prometheus' Android 4.2.2 or similar's useful life, Kodi v17

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Extend your Prometheus' Android 4.2.2 or similar's useful life, Kodi v17

    XBMC 12 and 13 are a little long in the tooth in 2018, but so is my Prometheus. It has Android 4.2.2, not even 4.4.x. Last working XBMC aka Kodi for this is v16 Jarvis. But Kodi v15 and up won't work right?

    Two things must be fixed. One, is permissions on the AM Logic devices and hardware codec. The Kodi developers decided to stop using hacks to get around permission issues. See https://forum.kodi.tv/showthread.php?tid=229310

    This is what you need to do:

    Code:
    chmod 666 /sys/class/display/mode
    chmod 666 /dev/amvideo
    chmod 666 /dev/amstream*
    chmod 666 /sys/class/video/axis
    chmod 666 /sys/class/video/screen_mode
    chmod 666 /sys/class/video/disable_video
    chmod 666 /sys/class/tsync/pts_pcrscr
    chmod 666 /sys/class/audiodsp/digital_raw
    chmod 666 /sys/class/ppmgr/ppmgr_3d_mode
    chmod 666 /sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq
    chmod 666 /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq
    chmod 666 /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
    I added this to the /etc/install-recovery.sh (su, remount system, add write access, add commands at end.) since I don't have init.d. Finless for Prometheus has init.d, but I don't know if these permission changes are needed for his rom. Or use Universal Init.d from the Play store (See https://forum.kodi.tv/showthread.php?tid=229310)

    Two, since Kodi 17 won't work on Android 4.2.2, we must use a fork. Not a kitchen fork, but a software fork. Community Edition Media Center aka CEMC is a fork of Kodi v16, with Backports of Kodi 17 features. Mainly HTTPS support and allowing Kodi v17 Repos and Add Ons!

    https://play.google.com/store/apps/d...bmc.cemc&hl=en
    Click image for larger version

Name:	unnamed.png
Views:	1
Size:	177.1 KB
ID:	707448

    Just install it. It will migrate your existing XBMC library to it. That's all you need to do. You just extended the life of your old 4.2.2 Prometheus for a year or two. Keep in mind this won't give you x265 or HEVC hardware support, so make sure you "encode" in x264.

    Good thing too. You can't find any good looking boxes any more, just squares.
Working...
X