Announcement

Collapse
No announcement yet.

create /dev/block/env on x8-h with probox2-ex

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • create /dev/block/env on x8-h with probox2-ex

    Hi, Iam new to this forums, I see you guys did a great work here. I have a problem and need some help. I just installed the PROBOX2-EX firmware on my x8-h. it works great. Iam just having an issue that after I enable the CEC and set the screen position and turn off the tv the settings I changed dont persist. so I have to set the CEC and the screen position every time I turn on the tv, which sucks.

    looking at the logcat, i see the process systemcontrol is trying to read the setting from the /dev/block/env device and it fails because of a CRC error, the /dev/block/env on my device is empty, fdisk says no partition table.

    has anyone came across similar issue? what the type of this device should be? can anyone share the details of the /dev/block/env from a probox device?

    thank you

  • #2
    Nevermind got it sorted out!

    Comment


    • #3
      What was the resolution?
      MXIII-G II, Chuwi Hibox, Nvidia Shield, NUC6CAYH

      Comment


      • #4
        Originally posted by bluesmanuk View Post
        What was the resolution?
        I ended up patching the systemcontrol binary to bypass the CRC check. the systemcontrol then started to save the settings in the env partition. dirty fix, but works. why the uboot doesnt populate the env partition is a mystery to me.

        btw, the screen position settings persist across reboots, but the CEC still goes off after the reboot, there seems to be another issue with CEC. Will try to look at it.

        Comment


        • #5
          Thanks for sharing.

          I'm sure that this may help others with the same issue in the future.
          MXIII-G II, Chuwi Hibox, Nvidia Shield, NUC6CAYH

          Comment


          • #6
            Originally posted by dedoz View Post

            I ended up patching the systemcontrol binary to bypass the CRC check. the systemcontrol then started to save the settings in the env partition. dirty fix, but works. why the uboot doesnt populate the env partition is a mystery to me.

            btw, the screen position settings persist across reboots, but the CEC still goes off after the reboot, there seems to be another issue with CEC. Will try to look at it.
            Can you post a link to your patched binary file please?

            Comment


            • #7
              Originally posted by mrdude View Post

              Can you post a link to your patched binary file please?
              attached! backup the original, just in case. remove the .txt extension.
              Attached Files

              Comment


              • #8
                Originally posted by dedoz View Post

                attached! backup the original, just in case. remove the .txt extension.
                Thank you for the quick reply and posting the file, I am sure others will appreciate this as much as I do.

                Comment


                • #9
                  Originally posted by mrdude View Post

                  Thank you for the quick reply and posting the file, I am sure others will appreciate this as much as I do.
                  No issue, enjoy!

                  Comment


                  • #10
                    Thank you Sir! I'm the 1st one appreciating (after mrdude , of course)

                    Comment


                    • #11
                      How can I copy systemcontrol file to the system directory? My ES file manager does not give access...
                      --------------
                      thanks, done everything: with new systemcontrol the screen size is saved after the restart. Thanks again!
                      Last edited by ruder1; 10-09-2017, 03:28.

                      Comment


                      • #12
                        Originally posted by ruder1 View Post
                        How can I copy systemcontrol file to the system directory? My ES file manager does not give access...
                        --------------
                        thanks, done everything
                        Use root explorer, when you try and copy it will ask if you want to set the folder to R/W mode - select yes, after you copy the file remember and set the file to the correct permission - octal 0644

                        Comment

                        Working...
                        X