Announcement

Collapse
No announcement yet.

Linux for Amlogic S802 \ S812

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Linux for Amlogic S802 \ S812

    Test alpha images. The main purpose - a basic assessment of health schedules (a bunch of the kernel + dtb). To check system startup you need to activate the multi-boot (all required files included in the images). On my sample s812 activation multi-boot is possible only with SD card, maybe on other devices it works with USB. After activating a multi-boot system running from USB (I'm running every test with USB flash drives). Please check the possibility of launching on the platform s802. Pay attention - the system must copy the appropriate dtb file with the name "dtb.img".



    https://yadi.sk/d/wc2jqGsHuKy48

  • #2
    Update images.

    Comment


    • #3
      Thanks mate, i will test it soon on Mxiii-c

      Comment


      • #4
        menthorul you have mx3 clone box with s802 cpu ? I have mx3 clone box with demaged nand and i want to boot android os or similar os using sd card. balbes150 is posible to boot linux on mx3 clone box and do i need to modificate the u-boot file on sd.Do you have some instruction or vidio how to boot linux os with sd

        Comment


        • #5
          Originally posted by tani666 View Post
          menthorul you have mx3 clone box with s802 cpu ? I have mx3 clone box with demaged nand and i want to boot android os or similar os using sd card. balbes150 is posible to boot linux on mx3 clone box and do i need to modificate the u-boot file on sd.Do you have some instruction or vidio how to boot linux os with sd

          You have connected the console UART ?

          Comment


          • #6
            I have 2 boxes:
            1. Mxiii-g ( mxiii-c 2gb / 16gb ) fully working with fw 202 L1
            2. Mxiii 4k unresurected yet, red light is the only light, with 2% stucked on writting the image on nand... but i collected a dozen of different .img files to find a solution..so, recovery is on progress...

            Comment


            • #7
              I've tried booting from SD Card with my MXIII 4k S802 - It seems it has tendency booting from SD card, but then only black screen. Once I managed to see LibreElec Logotype. Does it matter wich build I have on internal memory? I have Teamwin recovery. Thank you

              Comment


              • #8
                Originally posted by balbes150 View Post


                You have connected the console UART ?
                i have usb to ttl but i am not able to see any mesage in putty.What console uart you suggest.I have 2 different usb to ttl but none of them works.Its look like the usb to ttl are only compatible with aurdino or i have made some mistake connection the cable with box.

                Comment


                • #9
                  the first usb to ttl images are in the links
                  https://drive.google.com/open?id=0By...0oxN1lDTUltWnc
                  https://drive.google.com/open?id=0By...1BRVVd2d0FSTXM


                  the second usb to ttl images link below
                  https://drive.google.com/open?id=0By...jFkQUJJWDRKalE
                  https://drive.google.com/open?id=0By...Eg2bElqVDJGQ3c

                  Comment


                  • #10
                    Originally posted by Kentril View Post
                    I've tried booting from SD Card with my MXIII 4k S802 - It seems it has tendency booting from SD card, but then only black screen. Once I managed to see LibreElec Logotype. Does it matter wich build I have on internal memory? I have Teamwin recovery. Thank you
                    Have you trayed this firmware with sd card method https://drive.google.com/open?id=0By...mVQUWRRM3VHSVk

                    Comment


                    • #11
                      or this https://drive.google.com/open?id=0By...WU0R0U5RG85Q3M
                      or the img from my link https://drive.google.com/open?id=0By...EFkblRXRm5LWlE

                      Comment


                      • #12
                        @menthorul see my link here that i have posted for Kentril maybe one of the firmware will unbrick your mx3 box

                        Comment


                        • #13
                          Originally posted by Kentril View Post
                          I've tried booting from SD Card with my MXIII 4k S802 - It seems it has tendency booting from SD card, but then only black screen. Once I managed to see LibreElec Logotype. Does it matter wich build I have on internal memory? I have Teamwin recovery. Thank you

                          To run the system you need to manually copy it to the root of the media the correct dtb file with the name "dtb.img" .

                          Comment


                          • #14
                            Originally posted by tani666 View Post

                            i have usb to ttl but i am not able to see any mesage in putty.What console uart you suggest.I have 2 different usb to ttl but none of them works.Its look like the usb to ttl are only compatible with aurdino or i have made some mistake connection the cable with box.

                            Any of these modules USB to TTL is suitable for the connection. If there is no display information - so not correctly configured. You can try to swap the Tx and Rx contacts. Sometimes they are signed "on the contrary". More detailed information on configuring the UART is in the section of this forum about S905.

                            Comment


                            • #15
                              Originally posted by tani666 View Post

                              Have you trayed this firmware with sd card method https://drive.google.com/open?id=0By...mVQUWRRM3VHSVk
                              Is there any instruction?
                              Or just simply unzip file onto SDcard? Thank you

                              Comment

                              Working...
                              X