Announcement

Collapse
No announcement yet.

Linux for Amlogic S802 \ S812

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Updated version Armbian 5.27 for s802\s812. Running a wired network. For network card you need to use the right dtb file prefix for 1000 is a Gigabit network card. Tested on Tronsmart MIII Plus.

    https://yadi.sk/d/QCGU0PIv3G5kEa


    The dtb files MIII_Plus M8S_Plus is NOT working.

    To use the WiFi on the Ubuntu Mate (until I have time to add support for Wi-Fi only in this way). Connect the dhd module or other suitable part of the image. On Tronsmart MIII Plus the Wifi network (after activation of the module dhd) works (dtb meson8m2_n200_2G_1000).
    Last edited by balbes150; 03-17-2017, 06:45.

    Comment


    • #32
      Updated images Armbian 20170531. Changes to scripts activate the multi-boot and run system from external media. In the new version of the scripts allow to start the system from any USB socket (if the is connected other USB media). Back support "nodm", now in the images is used in common with the main branch Armbian authorization system. If you want you can install the package "lightdm" in version Mate-that-be to have a graphical authentication when you log into the system (just don't forget together with the installation of lightdm, remove the nodm package, otherwise they will interfere with each other). Other changes see the description of changes to main branch Armbian (replacement browser on Chromium, etc.).
      New scripts activate the multi-boot and system start-up can be found here. You can download them and use for old images. To reactivate the multi-boot again.
      https://yadi.sk/d/cEPIULGW3Jgpee
      https://yadi.sk/d/QCGU0PIv3G5kEa
      New script to activate the multi-boot on the Minix models H8x and H8x plus.
      https://yadi.sk/d/BU_pyfHW3JgpEP

      Comment


      • #33
        Interesting, but can't get it to boot.
        I used the following guide from: **New DIrections Start Here**
        1. burned "Armbian_5.27_S812_Ubuntu_xenial_3.10.99_mate_20170 531.img" to SD with Win32diskimager
        2. started my Minix X8-H Plus (updated to Lollipop already, does this matter?) and executed the update from settings (aml_autoscript.zip)
        3. Box rebooted, but didn' start up, even if I waited 10 minutes or more.



        This is the root of my SDcard, did I miss something, or do I have to copy one of the .dtb files to the root of the SD?
        Click image for larger version  Name:	 Views:	1 Size:	19.7 KB ID:	650617
        EDIT: dtb.img is missing, so I've tried some n200/2GB ones from the dtb folder, but still no boot.
        EDIT2: finally I've got it to boot, but only in 720p with heavy overscan.
        Last edited by vel2000; 06-07-2017, 03:52.

        Comment


        • #34
          Activation multi-boot on Minix requires an additional step. Create on the SD card in the first parted (FAT) of the additional /boot directory and copy the file boot.src (download to link). You can then activate multi-download. On models Minix script aml_autoscript is not working. The correct dtb.img in the root of the first partition of mandatory condition to start.

          https://yadi.sk/d/du9BkKk632MbMp

          Comment


          • #35
            Originally posted by balbes150 View Post
            Activation multi-boot on Minix requires an additional step. Create on the SD card in the first parted (FAT) of the additional /boot directory and copy the file boot.src (download to link). You can then activate multi-download. On models Minix script aml_autoscript is not working. The correct dtb.img in the root of the first partition of mandatory condition to start.

            https://yadi.sk/d/du9BkKk632MbMp
            Thanks for your reply, I finally got it working.
            The additional steps were not necessary, another dtb.img did the job.
            Now, I need to change the resolution from 720p to 1080p, because I have heavy overscan and can't read text or menus on the screen borders.

            Comment


            • #36
              Thank you, balbes150, for exellent job! i've tried to install last image on my M8S box, it work wery well!
              Only one dissapiontment: no HD media playback.... I've tried to install Kodi form Debian distro, but it even did not starts... I suppose, main problem is poor graphic support from Amlogic?
              But Kodi in OpenELEC include amlcodec with exellent performance at the (same?) kernel, so why you cannot use it in your images?
              Or, may be, there is any chance to compille Kodi fork for Armbian with same built-in Mali support as in OpenELEC?

              Comment


              • #37
                Originally posted by vel2000 View Post

                Thanks for your reply, I finally got it working.
                The additional steps were not necessary, another dtb.img did the job.
                Now, I need to change the resolution from 720p to 1080p, because I have heavy overscan and can't read text or menus on the screen borders.
                Change in script /boot/hdmi.sh of the first row.

                Comment


                • #38
                  Originally posted by serjy View Post
                  Thank you, balbes150, for exellent job! i've tried to install last image on my M8S box, it work wery well!
                  Only one dissapiontment: no HD media playback.... I've tried to install Kodi form Debian distro, but it even did not starts... I suppose, main problem is poor graphic support from Amlogic?
                  But Kodi in OpenELEC include amlcodec with exellent performance at the (same?) kernel, so why you cannot use it in your images?
                  Or, may be, there is any chance to compille Kodi fork for Armbian with same built-in Mali support as in OpenELEC?
                  To support the HW you need to rebuild all components with this support. Are you ready to do this ?

                  Comment


                  • #39
                    Originally posted by balbes150 View Post

                    To support the HW you need to rebuild all components with this support. Are you ready to do this ?
                    I think, Kodi package with amlcodec support will be enough for Armbian. All other applications (include browser) are fast enought. Problem is only with video playback.
                    Kodi includes plug-ins for for all most popular videoservices, so its only component that should be re-built, i suppose.

                    Comment


                    • #40
                      Originally posted by serjy View Post

                      I think, Kodi package with amlcodec support will be enough for Armbian. All other applications (include browser) are fast enought. Problem is only with video playback.
                      Kodi includes plug-ins for for all most popular videoservices, so its only component that should be re-built, i suppose.
                      KODI is a just a wrapper over the codecs, libraries and other software, they need the pen to collect with support for mali.

                      Comment


                      • #41
                        balbes150, thank you for reply) I know, this question was discussed million times, but i still not clear understend, why? If LibreELEC uses the same kernel, and Mali codec availible for it's Kodi build, why it not avalible in other Kody build for similar Linux OS at the same kernel?? where is a tric?)
                        As i suppose, main difference between LibreELEC and your Linux builds for Amlogic - additional grafic libraries and applications, but Kodi in LibreELEC does not requres it, so why we cannot build and run same Kodi on your Arclinux?

                        Comment


                        • #42
                          It's like trying to install only one motor from the truck to the passenger car. For this motor you need the appropriate wheels, body, etc.

                          Comment

                          Working...
                          X