Announcement

Collapse
No announcement yet.

MECOOL M8S Pro + TV Box Amlogic S905X Android 7.1 2/16GB Fast Lan, WiFi 802.11b/g/n

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Hello everybody.
    I too have freezing issues with my Mecool M8S Pro+. They also started when I flashed the ATV image.
    My box info:
    BB-ROC170811PS 2G+16G
    EMMC: SEC 652 KLMAGIJENB-B041 S565H02A
    Memory: D/G
    Supplier: Geekbuying

    I have tried couple of images and several methods. I can always get to the recovery (stock or TWRP, depending on the flashed image) and USB burning tool recognizes my box fine. I have had couple flash errors with the USB tool, but it has always flashed successfully in second time. I have not yet tried the newer images, but will do so probably tomorrow. My box appears to freeze randomly on different stages of the boot. It sometimes freezes on the "Mecool" screen and sometimes goes on trough to freeze on the "installing apps" screen.
    What I have seen on the serial debug out is that it does a kernel panic and a memory dump. I don't know if the dumps are any use to anybody, but I can upload couple next time I am at my workshop.

    Images I have tried so far:
    M8S_PRO+-NMF26Q-20170815.182813.V0321
    M8S_PRO+-V0321_TVStock-20170825

    Comment


    • Originally posted by Tieri View Post
      Hello everybody.
      I too have freezing issues with my Mecool M8S Pro+. They also started when I flashed the ATV image.
      My box info:
      BB-ROC170811PS 2G+16G
      EMMC: SEC 652 KLMAGIJENB-B041 S565H02A
      Memory: D/G
      Supplier: Geekbuying
      Don't even bother trying to fix it. You have a M8S Pro+ with faulty Samsung eMMC.
      Get a refund if you can from Geekbuying by following this link:

      http://freaktab.com/forum/advertiser...blem-post-here

      ===================

      #628.1
      scooter2014 commented
      10-11-2017, 20:17
      We dont get involved. Posting all over your wants /thoughts doesnt help. Post your order number issue in gearbest thread. Keep the laundry in the proper spot. No proof of what you claim.
      Yes I understand and as I've already said I've directed people to do exactly that. The vendor concerned was Geekbuying. Not Gearbest.

      Post in the correct location and if you paid with pay pal its a normal process. I am still little in dark of this issue seems some flashing wrong firmware and cant get back to L1 and pissed off for it thats not a defect.
      Please read the numerous M8S Pro+ threads. This faulty batch of Samsung 5.1 eMMC flash storage chips has nothing to do whatsoever with Firmware or L1.
      Users are Killing their boxes simply by flashing official Firmware on to faulty Samsung 5.1 eMMC equipped M8S Pro+
      Flashing Firmware should definitely not kill any Android box completely.

      Please do some further reading.

      I now have 6 of these ordered 2 more to see if i can see whats up here to. But one was dead after 2nd day refunded next day by gearbest i didnt even need to post a complaint in Thread.
      And I bet none of the new ones will have faulty Samsung 5.1 eMMC flash storage. New ones seem to be coming equipped with Kingston eMMC. You will not have issues then - unlike a bunch of other M8S Pro+ purchasers users from day 1.

      So go post in thread with your order number and list the issue with that order. Thats why it was set up here to help.
      That is exactly what I have done.

      Users should be able to discuss problematic Freaktab vendors in the actual device Hardware thread, completely independent of the Vendor thread - to warn other to stay away from them when purchasing in the future.

      Moderating the crap out of those sorts of comments is not on IMHO.

      Comment


      • Post in right area right way. Your the self appointed i see from your thread. Its not been confirmed that its a bad emmc. Also both geek and gear selling so point taken. But again Have you proof of this bad batch. Even manufacture is unsure so id like where and how you came up with that FACT.

        If a product is ordered and done so through pay pal ect protected on returns. Geekbuying and gear both have been very proactive in resolving issues on Freaktab by the support of Admins here at freaktab. Speading fear intimidation is not our way and we wont let you start this. Nor will you be allowed to post your rabble when and how you want. Do I make this very clear to you.

        Now that its posted lets see where and the response for geekbuying is. Seems others with the Listed numbers updated with NO ISSUE. So it remains to be seen what the actual issue is.
        Many devices now mk902ii/Shield/Mk68 /Ugoos/neox5/minix5 (yes they still work lol) mk80 no it doesnt work lol.

        Comment


        • My first box is now constantly crashing after flashing. (see previous posts in attached link). This happened before the problems with the EMMC were known. So I just asked for a replacement. But the replacement I got is presumably also one of the faulty ones. I find it a waste to try and flash it to just find out its useless after, Can anyone tell me what the chances are my new box is really faulty?

          Also any thoughts on just claiming another new revision model, without trying and ruining the current replacement?

          Click image for larger version

Name:	photo5976664322480384835.jpg
Views:	1
Size:	125.6 KB
ID:	677437
          (Broken box)

          Click image for larger version

Name:	photo5976664322480384834.jpg
Views:	1
Size:	126.3 KB
ID:	677436
          (Replacement (also faulty?) box)

          Thanks!
          WARNING: There's a bad batch of M8S Pro+ boxes which are experiencing regular freezing and crashes. We've narrowed the source of the problem down to a Samsung eMMC

          Comment


          • Originally posted by scooter2014 View Post
            Spreading fear intimidation is not our way and we wont let you start this. Nor will you be allowed to post your rabble when and how you want. Do I make this very clear to you.
            That is not the point I was trying to make. If it was misinterpreted I apologise.

            If vendor A is still selling old hardware that has a known problem then surely a user is entitled to post their feedback that Vendor B is selling hardware that actually works and warn others.

            If that sort of feedback is classified as rabble rousing then what is the Freaktab community forum actually for ?

            Geekbuying are now replying to M8S Pro+ faulty hardware queries, which is a good sign so yes I agree wait and we will see what happens.



            Comment


            • We still dont know that... Thats my point. Seems most are the ones with no reset. Manufacture maybe screw with device (not the first time we see this.) now geek/gear and other suppliers have to find why and when posted in thier section our users get the feed back overseen by us. Some buy nock offs too and not geek or gear and that to mix as well.

              Now that they posted in right place we see where it goes.

              Wont be last time we see hardware change after first shipment either

              It not old hardware those fine. Its new ones. If they ship you old one lucky you. Also funny cheap 36 dollar device level 1. I was impressed it actually booted let alone had a update

              Many devices now mk902ii/Shield/Mk68 /Ugoos/neox5/minix5 (yes they still work lol) mk80 no it doesnt work lol.

              Comment


              • Magendanz
                Magendanz commented
                Editing a comment
                Actually, the new ones with no reset switch have all had the Kingston eMMC, which hasn't had any reported problems.

              • scooter2014
                scooter2014 commented
                Editing a comment
                Ya look at board two posts up no reset. Kingston ones no issues? So wierd ill check few other I seen i cant remember if they had samsung or kingston now.

                Post 587 Kingston bricked by update plus few others i find so not limited to samsung but all no reset. ... So dont think bad emmc is this. Something else.

            • I agree with @ Magendanz - Kingston eMMC equipped boxes have Kingston stamped on the eMMC. These are good boxes.

              It seems from numerous user posts now, the (Samsung) eMMC 5.1 equipped boxes that are eMMC stamped SECxxx KLMAG1JENB B041 are causing the majority of problems. Post #587 is using KLMAG1JENB B041

              Originally posted by scooter2014 View Post
              I was impressed it actually booted let alone had a update
              Ha ha, now ain't that the truth - especially for the tight ass bargain hunter crew !
              Last edited by wrxtasy; 10-11-2017, 22:23.

              Comment


              • Did you even look at post 587? Bricked Kingston.... Shall i keep posting more kingston ones to prove it not just one batch of samsung emmc ? Is batch numbers... As lots with non samsung emmc... Different emmc makes check photos of thise posted here posts ones sent to me by others. It not Samsung emmc. It like Trebor post long time ago batch Numbers of affected.

                557 updated same emmc worked like a charm... As said It batch.... Maybe batch from main board bad sent to all factory (3) so that why different emmc on different chipset same issue and not have same on others. Not matter emmc samsung bo41 kingston.... But time keep bringing more infromation out... About 20 pages ago I did also state Anyone with one should get refunded by geek or gear. But no one posted in thier thread till yesterday.
                Last edited by scooter2014; 10-11-2017, 23:45.
                Many devices now mk902ii/Shield/Mk68 /Ugoos/neox5/minix5 (yes they still work lol) mk80 no it doesnt work lol.

                Comment


                • http://freaktab.com/forum/advertiser...f-today/page30

                  Hehehe it go on sale too pick up 3 or 4 before gone
                  Many devices now mk902ii/Shield/Mk68 /Ugoos/neox5/minix5 (yes they still work lol) mk80 no it doesnt work lol.

                  Comment


                  • Originally posted by scooter2014 View Post
                    http://freaktab.com/forum/advertiser...f-today/page30

                    Hehehe it go on sale too pick up 3 or 4 before gone
                    Code for single unit price only; VIP Price, Special Offer or Group Deal all exempt.

                    so i guess you can just get one!

                    Comment


                    • Originally posted by scooter2014 View Post
                      Did you even look at post 587? Bricked Kingston.... Shall i keep posting more kingston ones to prove it not just one batch of samsung emmc ? Is batch numbers... As lots with non samsung emmc... Different emmc makes check photos of thise posted here posts ones sent to me by others. It not Samsung emmc. It like Trebor post long time ago batch Numbers of affected.

                      557 updated same emmc worked like a charm... As said It batch.... Maybe batch from main board bad sent to all factory (3) so that why different emmc on different chipset same issue and not have same on others. Not matter emmc samsung bo41 kingston.... But time keep bringing more infromation out... About 20 pages ago I did also state Anyone with one should get refunded by geek or gear. But no one posted in thier thread till yesterday.
                      587 not about bricked Kingston (nor 586)

                      ??
                      http://freaktab.com/forum/tv-player-...821#post674821

                      586
                      10-01-2017, 14:15

                      Originally posted by stelakis1914 View Post
                      I am victim of cursed geekbying OTA update who destroyed my tv box. I have eMMC 5.1 chipset: SEC652 KLMAG1JENB B041 and the 20170829 stock firmware has work nice before. I extremely regret to take the decision to update. Now don't have many hopes to unbrick the TV Box.

                      587
                      Have you tried reverting to the 08.29 OEM FW ?
                      It has worked for a few ...
                      Hope you are lucky

                      Comment


                      • Originally posted by MortuuS View Post
                        My first box is now constantly crashing after flashing. (see previous posts in attached link). This happened before the problems with the EMMC were known. So I just asked for a replacement. But the replacement I got is presumably also one of the faulty ones. I find it a waste to try and flash it to just find out its useless after, Can anyone tell me what the chances are my new box is really faulty?

                        Also any thoughts on just claiming another new revision model, without trying and ruining the current replacement?

                        Click image for larger version  Name:	photo5976664322480384835.jpg Views:	1 Size:	125.6 KB ID:	677437
                        (Broken box)

                        Click image for larger version  Name:	photo5976664322480384834.jpg Views:	1 Size:	126.3 KB ID:	677436
                        (Replacement (also faulty?) box)

                        Thanks!
                        Hi,

                        Your first (top pic) broken box has a much earlier build date than the SEC 5.1 change and has a SAMSUNG 5.0 chip

                        The mode of failure is also not quite the same (though the final outcome is similar).
                        You stated you had crashes/reboots ? Is that correct.
                        If it is then you may have a faulty early box with a slightly different issue that has joined the Freeze-OneFlash group in error.


                        #303 ATV Thread
                        09-15-2017, 09:46



                        Originally posted by Magendanz View Post

                        There might be an issue with the 20170815 OEM firmware release, upon which this custom ROM was built. Have you tried rolling back to the 20170730 release? (This was available only as an OTA update, so install in TWRP and don't forget to do a Wipe first) https://1drv.ms/u/s!AoqocX31ecnXgZ0C0X-jM77e3x1oyQ


                        MortuuS



                        Through TWRP I performed the default wipe (factory reset) and then installed the zip you suggested. But still the same problem, it wasn't even possible to do the required Google sign in.
                        com.android.provision and several other processes randomly crash. The reboots sometimes even happen while the boot logo is still showing.
                        Earlier I noticed some video glitches as well... I'm declaring this one DOA.





                        • #303.1

                          Magendanz commented
                          09-15-2017, 10:22


                          Yep, I think you got a bad unit. A common problem is a poorly seated heat sink, which can cause them to quickly overheat. (Depending on the chipset design, this can result in a hang or a reset.)

                        Comment


                        • The issue I first noticed with the FW- 20170829.121624.V0321 + SEC 5.1 boxes was random Freezes - requiring the power to be removed.
                          After just one Update FW Flash via installed update app to OEM Update .zip as suggested by GearBest CS
                          the box then crashes between 10-20 seconds after power up - From initial MECOOL Logo, through Splash Video, up to just into First Time Setup- do Not Turn Off - message.
                          Totally randomly - it seems.

                          #308 ATV Thread

                          .
                          Originally posted by P.X View Post
                          Hi,

                          My second box arrived from BG - Quick 10 days to arrive.
                          ...
                          Bad news - Initially seemed OK testing with OEM ROM 7.1.1 NMF26Q 20170829.121624.V0321 but then it started freezing. Can be 20 seconds or 15 minutes but if freezes a lot - it seems to be every time !
                          Box doesn't seem to be getting hot, but that would be my guess.
                          Don't want to re-flash as it might happen during and .... BAD !

                          Seems to be a bit of a lottery going on. Some good , some bad

                          Video of a couple of freezes (Shaky, hand held, excuses, excuses etc.)
                          https://youtu.be/3SE1ro4GxEo

                          Pete
                          I subsequently opened the box and discovered the eMMC chip change to SEC 5.1
                          The FW installed at build time was the 20170829 version that has never been released by VS as a Zip or INF

                          This common issue with a certain set of boxes is not due to poor flashing, or errors flashing, or with a custom ROM (VS may think it is hence the Reset Button Removal)
                          It happens to a box that has been updated once using the official FW Updater built in, and flashing a CS provided OEM Zip FW.

                          Looking at some of the photos posted the introduction of the SEC 5.1 eMMC is not at a specific build date - The first picture of an early build in the original Tear-down is of a 5.1 chip while later ones built are then 5.0 and change to 5.1 again later ...
                          I do not know if there are different production facilities or just lines and chips taken at random from a big pile !!!

                          Can anyone who has them post links to Kingston eMMC versions with issues so I can check the specifics.

                          Last edited by P.X; 10-12-2017, 07:01.

                          Comment


                          • OK. I got my box working again. I flashed the 0829_V0321 image made by Magendanz with USB Burn tool V2.1.2. Big thank you to Magendanz for uploading it! I also tried the 0919_V0619 (supplied by Geekbying) by USB OTA update. The update completed successfully, but had similar freezing as with the 0825_V0312 FW and Magendanz ATV FW.

                            I have attached some serial debug logs from failed boots and one successful boot with the 0829_V0321 FW.
                            Some errors it is giving are:
                            Internal error: Oops: 96000045 [#1] PREEMPT SMP (FW=0825_V0321)
                            Internal error: Oops: 96000046 [#1] PREEMPT SMP (FW=0825_V0321)
                            Internal error: Oops: 96000005 [#1] PREEMPT SMP (FW=0825_V0321)
                            Internal error: Oops: 96000004 [#1] PREEMPT SMP (FW=0825_V0321)
                            Internal error: Oops - undefined instruction: 0 [#1] PREEMPT SMP (FW=0919_V0619)

                            Sometimes there is "Unable to handle kernel NULL pointer dereference at virtual address" or "Unable to handle kernel paging request at virtual address" before the Internal error.
                            I have had all these errors with all the non compatible FW's including Magendanz's M8S_PRO+-V0321_TVStock-20170825.
                            They seem to come at random times, but the boot process never goes beyond the "Starting first time installation, please don't power off!" screen.

                            I hope this is useful to someone who is more into android kernels and inner workings and maybe we can get working custom ROM's and updated OEM ROM's to these problematic devices.

                            I was thinking (not implying!) could it be that someone has sold geekbuying a batch of cloned/faked devices that have some different components than the originals? I have had this kind of thing happen to me before with certain tablet and dealextreme. The tabled had hacked FW that gave false information about the CPU, RAM and NAND. MTK droid tools showed totally different CPU that it should had, there was only half the amount of RAM and NAND over written itself at halfway. Dealextreme handled the issue so smoothly that it was my final order from them, for ever.

                            Edit: I forgot to add. I still have L1 widevine, even though I used full erase and force erase with the USB burning tool 2.1.2. I never ticked the erase key option! This DOES NOT mean that you may be safe using those options!
                            Edit2: I messed up the mecoolm8sproplus_0829_V0321_Succefull_boot.txt file. I have replaced it with the correct file.
                            Attached Files
                            Last edited by Tieri; 10-12-2017, 10:35.

                            Comment


                            • Magendanz
                              Magendanz commented
                              Editing a comment
                              Great data dump here. Thanks, Tieri!

                          • @Tieri

                            Thanks - Hope some expert can work out what is happening ...

                            Comment

                            Working...
                            X