Announcement

Collapse
No announcement yet.

S905X Android 8.0 Oreo (Tested on Mini M8S II. Possibile to work on other GXL/S905X boxes. Testing needed! "WIP")

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    That mean something is weong with dtb or recovery you use or try difreand sd card or pendrive (must be formated to fat32). Anyway that frezze its a sign that kernel and dtb are readed.
    Everything is possible if we work together!
    ApkFreak

    BItcoin Donate: 1K9Qh9CvxvpdkCANVU173Mh3WAjv3oMgQy

    Comment


      Ok. Thx for the infos. Will help me for sure in the future.
      Finally i saved my box. I found some old windows 7 pc
      in the storage room....puhhh

      Comment


        Hi guys & lewy thank you for your efforts.


        I installed this rom on my Mini M8S II (V3.1_20160615 PCB) straight from a TF card and it booted without problems. Unfortunately there are some bugs that make my everyday use quite difficult and these are:

        1) Cannot click on some drop-down lists - the final choice after clicking is some random one. I have to use the cursor keys to navigate to a choice and press enter. Using the Microsoft wireless keyboard that has a trackpad.

        2) Cannot drag icons when on desktop (or bring them on desktop by dragging) so I can't make a nice desktop with my favorite look.

        3) I tried to go back to original rom using update.zip but the device is no longer recognised as a "p212" but a "" (this is the error I get when trying to flash stock update.zip from recovery)



        Please let me know if you are planning to provide an update without bugs (will be happy to donate for an improved version) or please let me know how can I go back to stock rom.

        All the best,
        George

        Comment


          Originally posted by blackThirteen View Post
          Ok. Thx for the infos. Will help me for sure in the future.
          Finally i saved my box. I found some old windows 7 pc
          in the storage room....puhhh
          I think I have the same problem like you - I need to go back to stock rom but can't. Can you please provide some instructions?

          Comment


            In the past i always used my windows 10 pc without problems, it was rocksolid. So after i flashed this rom, weeks later, a couple of days ago i tried to go back,
            because of the lack support for my lan and wlan.

            First i thought, it was my handmade usb man to man cable. Then i thought, because of flashing oreo the resetbutton is out of function. But last i took
            some old pc with windows 7. Sampled 2 or 3 times with resetbutton and bam, burningtool flashed my box finally.

            Comment


              So you did it with a USB cable. Can you please provide the pinout since I need to make one, too. If you could also share the steps of the procedure that'd be great. I have so far installed the software and the license.

              Comment


                Here you go for the cable:
                http://freaktab.com/forum/tv-player-...lashing-tv-box

                Flashing with burningtool was just normal like all
                the videos on youtube.

                Comment


                  Originally posted by blackThirteen View Post
                  Here you go for the cable:
                  http://freaktab.com/forum/tv-player-...lashing-tv-box

                  Flashing with burningtool was just normal like all
                  the videos on youtube.
                  really appreciate it!

                  EDIT: all went well Im back to v112. Hope Oreo rom gets improved!!! Thank you black.
                  Last edited by f-bone; 07-13-2018, 12:00.

                  Comment


                    Hi,
                    I'm keen on testing. My device is wit s905x SoC and with hs2734a wifi chip. Will this rom works on my M96X mini 2/16gb tv box ? If so I will be happy to test!

                    Comment


                      Ok i have tested this oreo version and it works on on X96 S905x,but i have three drawbacks that makes me switch.
                      1.The wifi is super slow,max 250 kb/s.I have two routers with 1Gigabit connection,both same speeds.
                      *on cable it works i get 1mb altho on the old rom i would get in wifi 3-4 mb and on cable 10mb download.That is because it has a 10MB ethernet.
                      2.Youtube doesn't play back properly! the image becomes green and it crashes the app.That only above at 720p or 1080p rezolution
                      3.The speed of the UI or the Rom itself,to explain a bit more:
                      The mouse is moving but it is not so snappy,it has a small delay all the time
                      The overall speed of the rom seems ok but i have the feeling there's something missing/slow,being used to the other rom i can notice a difference.

                      Mine doesn't have bluetooth so i had to freeze the app,it was ok with Titanium backup after that the app didn't pop up telling me it has crashed.
                      The overall speed of the ROM is decent but i would describe it as medium compared to the stock firmware or the Nexbox 7.1.2 firmware which i am running currently.
                      This is a very promissing ROM in my opinion.All it needs is those fixes.

                      Thank you for your work so far.I really appreciate it
                      If you need more info let me know.

                      Comment


                        It work fine and Thanks for your work!
                        The wifi is little slow. it seem improved by turning off bluetooth. The wifi speed is not big issue. It will be great if support either NTFS or exFAT.
                        Thanks again!

                        Comment


                          To those that are looking to drag/drop icons to the homescree:

                          I don't think these TV boxes have that functionality because I was looking for the same thing...but I could be wrong... I've had other TV boxes and none could drag drop icons. Your best option is to install a TV launcher that allows you to add icons and shortcuts to your home screen. I'm currently using, yup, TV Launcher. it's free on Play Store. works really nice.

                          Also, I've tested this Oreo version and so far so good. I've tested it for multiple applications like kodi, youtube, twitch, and numerous rom emulators. All work perfectly. no crashes of any kind. I had to side-load Netflix , but it does works once you log in.

                          Also, this Oreo 8.0 os is really smooth and fast. I'm using it on a Mini M8S II. Upgraded it from 6.0 using USB burning took. Even switched back and forth to 6.0 just to see if it works.

                          Thanks Lewy for this rom

                          Comment


                            Originally posted by metrometro View Post
                            To those that are looking to drag/drop icons to the homescree:

                            I don't think these TV boxes have that functionality because I was looking for the same thing...but I could be wrong... I've had other TV boxes and none could drag drop icons. Your best option is to install a TV launcher that allows you to add icons and shortcuts to your home screen. I'm currently using, yup, TV Launcher. it's free on Play Store. works really nice.

                            Also, I've tested this Oreo version and so far so good. I've tested it for multiple applications like kodi, youtube, twitch, and numerous rom emulators. All work perfectly. no crashes of any kind. I had to side-load Netflix , but it does works once you log in.

                            Also, this Oreo 8.0 os is really smooth and fast. I'm using it on a Mini M8S II. Upgraded it from 6.0 using USB burning took. Even switched back and forth to 6.0 just to see if it works.

                            Thanks Lewy for this rom
                            Hello metrometro and lewy; I was able to flash this onto my M8S II box. Unfortunately it is not recognizing my WiFi. I am able to use it by providing an RJ45 wired connection and the build is very smooth. But I have to return the router with the RJ45 back to my friend and go back to using my purely WiFi router with 4G SIM. I tried the USB cable method to flash back an v112 based TVStock rom that I was using earlier but my Windows 10 machine is no longer recognizing the device when I press the paper clip into the pin hole. I even tried burning the img ffile using the card maker and inserting into the sdcard slot and hoping that when it reboots it will auto update and revert. In both cases it continues to boot into Lewy Oreo. I am able to get to Lew Oreo recover bu going into the UI and under OTA updates clicking on recovery to get the device to reboot and show the green robot awaiting instructions. I am a bit lost here on how should I proceed now to revert back to my old firmware. Any pointers much appreciated.

                            Comment


                              Originally posted by blrdude39 View Post

                              Hello metrometro and lewy; I was able to flash this onto my M8S II box. Unfortunately it is not recognizing my WiFi. I am able to use it by providing an RJ45 wired connection and the build is very smooth. But I have to return the router with the RJ45 back to my friend and go back to using my purely WiFi router with 4G SIM. I tried the USB cable method to flash back an v112 based TVStock rom that I was using earlier but my Windows 10 machine is no longer recognizing the device when I press the paper clip into the pin hole. I even tried burning the img ffile using the card maker and inserting into the sdcard slot and hoping that when it reboots it will auto update and revert. In both cases it continues to boot into Lewy Oreo. I am able to get to Lew Oreo recover bu going into the UI and under OTA updates clicking on recovery to get the device to reboot and show the green robot awaiting instructions. I am a bit lost here on how should I proceed now to revert back to my old firmware. Any pointers much appreciated.
                              bro try using the different USB port for flashing the img file with Amlogic tool .Mine device too refused to be recognised by AMlogic USB burning using the default USB port.

                              Comment


                                Originally posted by farzid View Post

                                bro try using the different USB port for flashing the img file with Amlogic tool .Mine device too refused to be recognised by AMlogic USB burning using the default USB port.
                                That is interesting. And I'm assuming you're connecting to the rear USB port of the TV box? The USB port next to the HDMI cable? I can't remember, but I may have flashed using the USB on the right side and that didn't work for me. And just to be sure you're also using a male-to-male USB Type-A cable at both ends, right? Lastly, I was using a v115. not sure if that matters or not.
                                Also, I'm not using WiFi. I have it connected to a RJ45 cable.

                                Comment

                                Working...
                                X