Announcement

Collapse
No announcement yet.

S905X Android 8.0 Oreo (Tested on Mini M8S II. Possibile to work on other GXL/S905X boxes. Testing needed! "WIP")

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    #46
    Originally posted by 01520717 View Post
    I loaded this onto a Sammix R95S box (a fairly standard 2G/16G p212 board) but it wouldn't boot. The power light came on the box but there was no sign of any activity and the TV screen was blank with no boot logo. I flashed it a second time but got the same result.

    The Sammix R95S is very similar to a Mini M8S II so it's odd it won't boot that image. If I get ambitious, I might pull out my soldering iron and get a serial console working so I can figure out what's wrong.
    I have the exactly same problem in x96 1/8 GB and mini m8s ii 1/8 GB.

    Comment


      #47
      Hm, this may probably hapen becouse non standard gxl dtb for this boxes.
      Everything is possible if we work together!
      ApkFreak

      BItcoin Donate: 1K9Qh9CvxvpdkCANVU173Mh3WAjv3oMgQy

      Comment


        #48
        please consider adding support for NTFS hd reading, like any other M8S II rom. Tank you

        Comment


          #49
          Originally posted by lewy20041 View Post
          Hm, this may probably hapen becouse non standard gxl dtb for this boxes.
          I've loaded some other standard S905X ROMs, e.g. XannyTech's XTMOD ROM, on my Sammix R95S and they worked fine so I assume the box must use a standard DTB. Plus I've compared the stock DTB with ones from Amlogic and they are almost identical. Amlogic changes their DTBs with each buildroot release so I'm not surprised there are a couple differences since I used an arbitrarily selected buildroot DTB for the comparison.

          I hooked up a serial console but didn't see any output from it so I'm beginning to wonder if something is preventing the bootloader from loading. I'll do a bit more testing with another ROM to make sure the serial console is working properly.

          Comment


            #50
            Hm, that strange. If that so it should work just fine. If you will be able to get some output from serial console please pos it here.
            Everything is possible if we work together!
            ApkFreak

            BItcoin Donate: 1K9Qh9CvxvpdkCANVU173Mh3WAjv3oMgQy

            Comment


              #51
              Originally posted by 01520717 View Post

              Were you using the USB port furthest away from the HDMI port?
              Thanks for reply, I use the number 1 (the most nearly), but I used too on this same usb port and I can install another firmware and worked perfectly. I don't understand the problem.

              Comment


                #52
                Originally posted by djvvb View Post

                Thanks for reply, I use the number 1 (the most nearly), but I used too on this same usb port and I can install another firmware and worked perfectly. I don't understand the problem.
                On my R95S, I have to use USB2 or it won't flash. Also, the burning tool will show the R95S is successfully connected even when it isn't. If you press the reset button after you see the error message, will the burning tool continue the flashing process?

                Comment


                  #53
                  I finally figured out why my serial console wasn't working... Iwithout thinking I connected Rx on my serial reader to Rx on the board and Tx to Tx. Once I realized that and fixed it, the serial console worked fine.

                  Here's the output from the failed boot on my Sammix R95S. There are several errors early in the boot process but it seems to continue to load the kernel, ramfs and dtb but it aborts shortly after that.

                  I'll compare this to a good boot of a Marshmallow image to try find out which error messages are important and which ones can be ignored.


                  GXL:BL1:9ac50e:a1974b;FEAT:ADFC318C;POC:3;RCY:0;EM MC:0;READ:0;0.0;CHK:0;
                  TE: 135943
                  BL2 Built : 15:56:15, Nov 21 2017. gxl gfa7b794 - zhongfu.luo@droid12
                  set vcck to 1120 mv
                  set vddee to 1000 mv
                  Board ID = 3
                  CPU clk: 1200MHz
                  DQS-corr enabled
                  DDR scramble enabled
                  DDR3 chl: Rank0+1 @ 912MHz - FAIL
                  DDR3 chl: Rank0 @ 912MHz
                  bist_test rank: 0 1b 01 35 2e 13 49 1a 00 35 2d 12 48 19 00 32 2d 11 49 18 00 30 2e 12 4a 676 - PASS
                  Rank0: 1024MB(auto)-2T-13
                  AddrBus test pass!
                  -s
                  emmc switch 3 ok
                  Authentication key not yet programmed
                  emmc_rpmb_key_is_programmed: error 0x00000007
                  emmc switch 0 ok
                  Load fip header from eMMC, src: 0x0000c200, des: 0x01400000, size: 0x00004000
                  New fip structure!
                  Load bl30 from eMMC, src: 0x00010200, des: 0x013c0000, size: 0x0000d600
                  Load bl31 from eMMC, src: 0x00020200, des: 0x05100000, size: 0x0003b600
                  Load bl33 from eMMC, src: 0x0005c200, des: 0x01000000, size: 0x00068200
                  NOTICE: BL3-1: v1.0(release):a75d708
                  NOTICE: BL3-1: Built : 17:16:24, Nov 22 2017
                  [BL31]: GXL CPU setup!
                  NOTICE: BL3-1: GXL normal boot!
                  NOTICE: BL3-1: BL33 decompress pass
                  mpu_config_enablek
                  [Image: gxl_v1.1.3255-1a77b01 2017-09-15 16:58:02 xiaobo.gu@droid12]
                  OPS=0x82
                  32 66 f 2e 86 c7 18 73 76 eb ac 36 [1.189804 Inits done]
                  secure task start!
                  high task start!
                  low task start!
                  ERROR: Error initializing runtime service opteed_fast
                  U-Boot 2015.01 (Mar 07 2018 - 10:19:00)
                  DRAM: 1 GiB
                  Relocation Offset is: 36eaa000
                  register usb cfg[0][1] = 0000000037f55da8
                  [CANVAS]canvas init
                  boot_device_flag : 1
                  Nand PHY Ver:1.01.001.0006 (c) 2013 Amlogic Inc.
                  init bus_cycle=6, bus_timing=7, system=5.0ns
                  reset failed
                  get_chip_type and ret:fffffffe
                  get_chip_type and ret:fffffffe
                  chip detect failed and ret:fffffffe
                  nandphy_init failed and ret=0xfffffff1
                  MMC: aml_priv->desc_buf = 0x0000000033eaa6b0
                  aml_priv->desc_buf = 0x0000000033eac9d0
                  SDIO Port B: 0, SDIO Port C: 1
                  emmc/sd response timeout, cmd8, status=0x1ff2800
                  emmc/sd response timeout, cmd55, status=0x1ff2800
                  original ext_csd[171] USE_WP field value is 50
                  ext_csd[171] USER_WP filed value after switch is 58
                  init_part() 293: PART_TYPE_AML
                  [mmc_init] mmc init success
                  start dts,buffer=0000000033eaf200,dt_addr=0000000033eaf2 00
                  get_partition_from_dts() 103: ret 0
                  parts: 14
                  00: logo 0000000000800000 1
                  01: recovery 0000000001800000 1
                  02: misc 0000000000800000 1
                  03: dto 0000000000800000 1
                  04: cri_data 0000000000800000 2
                  05: param 0000000001000000 2
                  06: boot 0000000001000000 1
                  07: rsv 0000000001000000 1
                  08: tee 0000000002000000 1
                  09: vendor 0000000010000000 1
                  10: odm 0000000010000000 1
                  11: system 0000000074000000 1
                  12: cache 0000000046000000 2
                  13: data ffffffffffffffff 4
                  init_part() 293: PART_TYPE_AML
                  eMMC/TSD partition table have been checked OK!
                  check pattern success
                  mmc env offset: 0x4d400000
                  In: serial
                  Out: serial
                  Err: serial
                  reboot_mode=cold_boot
                  [store]To run cmd[emmc dtb_read 0x1000000 0x40000]
                  _verify_dtb_checksum()-1078: calc 80840c53, store 80840c53
                  _verify_dtb_checksum()-1078: calc 80840c53, store 80840c53
                  dtb_read()-1200: total valid 2
                  dtb_read()-1267: do nothing
                  vpu: clk_level in dts: 7
                  vpu: set clk: 666667000Hz, readback: 666660000Hz(0x300)
                  vpu: vpu_clk_gate_init_off finish
                  vpp: vpp_init
                  hpd_state=0
                  cvbs performance type = 6, table = 0
                  Net: dwmac.c9410000amlkey_init() enter!
                  [EFUSE_MSG]keynum is 4
                  [BL31]: tee size: 0
                  MACADDR:02:73:76:eb:cc:dd(from chipid)
                  Warning: dwmac.c9410000 MAC addresses don't match:
                  Address in SROM is 9e:2a:75:e6:aa:bb
                  Address in environment is 02:73:76:eb:cc:dd
                  Start read misc partition datas!
                  info->magic =
                  info->version_major = 0
                  info->version_minor = 0
                  info->slots[0].priority = 0
                  info->slots[0].tries_remaining = 0
                  info->slots[0].successful_boot = 0
                  info->slots[1].priority = 0
                  info->slots[1].tries_remaining = 0
                  info->slots[1].successful_boot = 0
                  Magic is incorrect.
                  boot-info is invalid. Resetting.
                  save boot-info
                  info->magic =
                  info->version_major = 1
                  info->version_minor = 0
                  info->slots[0].priority = 15
                  info->slots[0].tries_remaining = 7
                  info->slots[0].successful_boot = 0
                  info->slots[1].priority = 14
                  info->slots[1].tries_remaining = 7
                  info->slots[1].successful_boot = 0
                  active slot = 0
                  wipe_data=successful
                  wipe_cache=successful
                  upgrade_step=2
                  [OSD]load fb addr from dts
                  [OSD]fb_addr for logo: 0x7f800000
                  [OSD]load fb addr from dts
                  [OSD]fb_addr for logo: 0x7f800000
                  [CANVAS]addr=0x7f800000 width=3840, height=2160
                  amlkey_init() enter!
                  amlkey_init() 71: already init!
                  [EFUSE_MSG]keynum is 4
                  [BL31]: tee size: 0
                  [KM]Error:f[key_manage_query_size]L507:key[usid] not programed yet
                  [KM]Error:f[key_manage_query_size]L507:key[deviceid] not programed yet
                  saradc - saradc sub-system
                  Usage:
                  saradc saradc open <channel> - open a SARADC channel
                  saradc close - close the SARADC
                  saradc getval - get the value in current channel
                  saradc test - test the SARADC by channel-7
                  saradc get_in_range <min> <max> - return 0 if current value in the range of current channel
                  Hit Enter or space or Ctrl+C key to stop autoboot -- : 1 0
                  (Re)start USB...
                  USB0: USB3.0 XHCI init start
                  Register 2000140 NbrPorts 2
                  Starting the controller
                  USB XHCI 1.00
                  scanning bus 0 for devices... 1 USB Device(s) found
                  scanning usb for storage devices... 0 Storage Device(s) found
                  ** Bad device usb 0 **
                  card out
                  [sd_inand_staff_init][246], debug
                  emmc/sd response timeout, cmd8, status=0x1ff2800
                  emmc/sd response timeout, cmd55, status=0x1ff2800
                  emmc/sd response timeout, cmd1, status=0x1ff2800
                  (Re)start USB...
                  USB0: USB3.0 XHCI init start
                  Register 2000140 NbrPorts 2
                  Starting the controller
                  USB XHCI 1.00
                  scanning bus 0 for devices... 1 USB Device(s) found
                  scanning usb for storage devices... 0 Storage Device(s) found
                  ** Bad device usb 0 **
                  emmc/sd response timeout, cmd8, status=0x1ff2800
                  emmc/sd response timeout, cmd55, status=0x1ff2800
                  emmc/sd response timeout, cmd1, status=0x1ff2800
                  ee_gate_off ...
                  ## Booting Android Image at 0x01080000 ...
                  reloc_addr =33f2f450
                  copy done
                  Kernel command line: otg_device=0
                  load dtb from 0x1000000 ......
                  Uncompressing Kernel Image ... OK
                  kernel loaded at 0x01080000, end = 0x026e1a00
                  Loading Ramdisk to 33ce0000, end 33e981a8 ... OK
                  Loading Device Tree to 000000001fff1000, end 000000001ffff2f4 ... OK
                  fdt_instaboot: no instaboot image
                  Starting kernel ...
                  uboot time: 5400019 us
                  [ 0.000000@0] Booting Linux on physical CPU 0x0
                  [ 0.000000@0] Linux version 4.9.61 (lewy@ubuntu) (gcc version 4.9.2 20140904 (prerelease) (crosstool-NG linaro-1.13.1-4.9-2014.09 - Linaro GCC 4.9-2014.09) ) #36 SMP PREEMPT Tue Mar 13 12:53:46 CET 2018
                  [ 0.000000@0] Boot CPU: AArch64 Processor [410fd034]
                  [ 0.000000@0] earlycon: aml_uart0 at MMIO 0x00000000c81004c0 (options '')
                  [ 0.000000@0] bootconsole [aml_uart0] enabled
                  [ 0.000000@0] Bad mode in Error handler detected on CPU0, code 0xbf000000 -- SError
                  [ 0.000000@0] Internal error: Oops - bad mode: 0 [#1] PREEMPT SMP
                  [ 0.000000@0] Modules linked in:
                  [ 0.000000@0] CPU: 0 PID: 0 Comm: swapper Not tainted 4.9.61 #36
                  [ 0.000000@0] Hardware name: Amlogic (DT)
                  [ 0.000000@0] task: ffffff800a578700 task.stack: ffffff800a560000
                  [ 0.000000@0] PC is at setup_arch+0x108/0x5a4
                  [ 0.000000@0] LR is at setup_arch+0x104/0x5a4
                  [ 0.000000@0] pc : [<ffffff800a113b28>] lr : [<ffffff800a113b24>] pstate: 000000c5
                  [ 0.000000@0] sp : ffffff800a563f10
                  [ 0.000000@0] x29: ffffff800a563f10 x28: 0000000002110018
                  [ 0.000000@0] x27: 0000000037f5fb58 x26: 0000000033eaf848
                  [ 0.000000@0] x25: ffffff800a569000 x24: 0000000000000000
                  [ 0.000000@0] x23: ffffff800a569000 x22: ffffff800a6e5000
                  [ 0.000000@0] x21: ffffffbefe9f1000 x20: ffffff800a5ab000
                  [ 0.000000@0] x19: ffffff8009080000 x18: 0000000000000027
                  [ 0.000000@0] x17: 0000000000001810 x16: 0000000000001000
                  [ 0.000000@0] x15: 0000000000001c00 x14: 0000000000000000
                  [ 0.000000@0] x13: 0000000000000007 x12: 0000000000000010
                  [ 0.000000@0] x11: 0000000000000004 x10: 0101010101010101
                  [ 0.000000@0] x9 : fefefefefefefeff x8 : 7f7f7f7f7f7f7f7f
                  [ 0.000000@0] x7 : 687564635e66736e x6 : 0c1b092c0b091369
                  [ 0.000000@0] x5 : 6913090b2c091b0c x4 : 0000000000000000
                  [ 0.000000@0] x3 : 0000000000000000 x2 : 00000000000000f7
                  [ 0.000000@0] x1 : 0000000000000000 x0 : 0000000000000001
                  [ 0.000000@0]
                  [ 0.000000@0] Process swapper (pid: 0, stack limit = 0xffffff800a560020)
                  [ 0.000000@0] Stack: (0xffffff800a563f10 to 0xffffff800a564000)
                  [ 0.000000@0] 3f00: ffffff800a563f90 ffffff800a1108d8
                  [ 0.000000@0] 3f20: ffffff800a1853a8 ffffff800a569000 ffffff800a6e5000 ffffff800a6e5000
                  [ 0.000000@0] 3f40: ffffff800a569000 0000000000000000 0000000000000000 0000000033eaf848
                  [ 0.000000@0] 3f60: 000000001fff1000 0000000000000001 ffffffffffffffff 0000000000000000
                  [ 0.000000@0] 3f80: 0000000000808080 000000000004093d ffffff800a563ff0 ffffff800a1101f8
                  [ 0.000000@0] 3fa0: 0000000034d5d91d 0000000030d00800 000000001fff1000 0000000000000000
                  [ 0.000000@0] 3fc0: 0000000000000000 0000000000000000 0000000000000000 000000001fff1000
                  [ 0.000000@0] 3fe0: ffffff800a1853a8 0000000000000000 0000000000000000 0000000001ca42bc
                  [ 0.000000@0] Call trace:
                  [ 0.000000@0] [<ffffff800a113b28>] setup_arch+0x108/0x5a4
                  [ 0.000000@0] [<ffffff800a1108d8>] start_kernel+0xbc/0x3f0
                  [ 0.000000@0] [<ffffff800a1101f8>] __primary_switched+0x74/0x8c
                  [ 0.000000@0] Code: 9134c000 940036e9 97fff32a d50344ff (d5384100)
                  [ 0.000000@0] ---[ end trace f68728a0d3053b52 ]---
                  [ 0.000000@0] Kernel panic - not syncing: Attempted to kill the idle task!
                  [ 0.000000@0] ---[ end Kernel panic - not syncing: Attempted to kill the idle task!

                  Last edited by 1520717; 03-27-2018, 13:54.

                  Comment


                    #54
                    Looks like dtb issue:"
                    Everything is possible if we work together!
                    ApkFreak

                    BItcoin Donate: 1K9Qh9CvxvpdkCANVU173Mh3WAjv3oMgQy

                    Comment


                      #55
                      Yes, I agree the DTB must be different for my R95S. If I get time, I'll compare a Marshmallow or Nougat Mini M8S II DTB with a R95S DTB to see where the differences are.

                      Comment


                        #56
                        You need to remember that oreo is using kernel 4.9 instead of 3.14 so there will be many difreances there to.
                        As you say you can compare the two from marshmelow or nugat and find the difreance and aply some changes to dtb from this rom if you are familiar with linux dtc tool. Also once done makeing changes to dtb you can test by placing boot.img (rename to kernel.img) and dtb.img on sdcard or usb (try difreant ports).
                        Everything is possible if we work together!
                        ApkFreak

                        BItcoin Donate: 1K9Qh9CvxvpdkCANVU173Mh3WAjv3oMgQy

                        Comment


                          #57
                          Did you use the standard device tree released by AMLogic or are you using one that was customized for the Mini M8S II?

                          Comment


                            #58
                            I compared the Mini M8S II dtb from the rv112 firmware to the dtb from the R95S and they are very similar. Here is a UNIX diff of the two dts files. It's odd they are so similar and yet the R95S can't load the Mini M8S II Oreo image.

                            I can apply these changes to the Oreo DTB and see what happens but I suspect there is something more wrong than the changes shown below since none of these differences seem that significant.

                            < is from Mini M8S II
                            > is from Sammix R95S

                            687,689c687,689 (these are audio pins)
                            < amlogic,setmask = <0x6 0x10000000>;
                            < amlogic,clrmask = <0x6 0x8000000>;
                            < amlogic,pins = "GPIOH_4";
                            ---
                            > amlogic,setmask = <0x10 0x10>;
                            > amlogic,clrmask = <0x10 0x8000000c>;
                            > amlogic,pins = "GPIOAO_9";
                            1032a1033,1048
                            > standbyled {
                            > compatible = "amlogic, standbyled";
                            > dev_name = "standbyled";
                            > status = "okay";
                            > led_gpio = <0x18 0x4b 0x0>;
                            > led_active_low = <0x1>;
                            > };
                            >
                            > irled {
                            > compatible = "amlogic, irled";
                            > dev_name = "irled";
                            > status = "okay";
                            > led_gpio = <0x18 0x4c 0x0>;
                            > led_active_low = <0x1>;
                            > };
                            >
                            1430c1446 (this is the system partition size)
                            < size = <0x0 0x60000000>;
                            ---
                            > size = <0x0 0x40000000>;
                            1907,1910c1923,1926
                            < key_num = <0x1>;
                            < key_name = "power";
                            < key_code = <0x74>;
                            < key_pin = <0x69 0x2 0x0>;
                            ---
                            > key_num = <0x2>;
                            > key_name = "power", "recovery";
                            > key_code = <0x74 0xf9>;
                            > key_pin = <0x69 0x2 0x0 0x69 0x3 0x0>;
                            1912a1929,1939
                            > };
                            >
                            > adc_keypad {
                            > compatible = "amlogic, adc_keypad";
                            > status = "okay";
                            > key_name = "recovery";
                            > key_num = <0x1>;
                            > key_code = <0xf9>;
                            > key_chan = <0x0>;
                            > key_val = <0x0>;
                            > key_tolerance = <0x28>;

                            Comment


                              #59
                              Hi There,
                              Installed the software on my S905XQ v2.0 with success. But when I connect to the TV it is just a black screen, blue led is on, no response from remote or wireless mouse. Rebooted with internet cable and SD card, still a black screen.
                              Any particular reason why?

                              Comment


                                #60
                                I was working on another project when I realized why this isn't loading on my Android box.

                                In the boot log, I noticed I have one of those boxes that was sold as having 2GB RAM but only one rank is recognized so only 1GB is usable. I edited Lewy's DTB for 1GB of RAM and now it runs fine on my box.

                                If Lewy's image won't boot on your box, use the Customization tool to unpack the first level then replace the _aml_dtb.PARTITION with the one attached here and repack the image. Then it should run on your box. I even took Lewy's update and it applied fine, i.e. it didn't change the DTB.
                                Attached Files
                                Last edited by 1520717; 04-02-2018, 06:23.

                                Comment

                                Working...
                                X