Announcement

Collapse
No announcement yet.

[ROM] Mecool M8S PRO+ TVStock Nexus ROM (Android TV 7.1)

Collapse
This is a sticky topic.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by clarkss12 View Post

    ?????? You are confusing me. You should be doing something similar to what I am showing in this video, but using a different box.

    https://www.youtube.com/watch?v=gaOuY94DGcU&t=18s
    Right, that's what I've been expecting to see but haven't. Your video is extremely informative and that's why I've been confused.

    From everyone's posts it seems no connection is being made so I'll have to get that squared away.

    Comment


    • Got it! I tried it by connecting the cable to the device first and then connecting it to the computer and I think that did the trick. As to why, I don't know, but it worked.

      Thanks everyone for your help!

      Comment


      • Originally posted by KBJ55 View Post
        Got it! I tried it by connecting the cable to the device first and then connecting it to the computer and I think that did the trick. As to why, I don't know, but it worked.

        Thanks everyone for your help!
        So, you were able to install this firmware by using the burn tool?
        MK818B, T428, ATV 1220, CS918S, TV01, S89H, R89, ADT-1, MK808B Plus, MINIX X8-H Plus, Tronsmart Orion R68

        Comment


        • Originally posted by clarkss12 View Post

          So, you were able to install this firmware by using the burn tool?
          Yes, I wanted to originally as it's been noted that that would provide for a cleaner install but went with the SD method as it was the easiest and at the time I didn't have a male-to-male USB cable anyway.

          I don't know it this will solve that stuttering problem with the HDHomeRun app although I should know in the next few days as I use the device.

          Comment


          • With this rom this box is almost perfect. No lags, Netflix, Youtube, simple games for kids. I'm almost not using my cable tv.
            I miss Chromecast. Good thing is that is OgYoutube, and with this app on my phone Chormecast works flawless.

            Many thanks for developer and community.

            Comment


            • I registered just to say a big Thank You to Magendanz. This firmware has made this box a thousand times better than the original firmware. I've got 2 boxes and flashed the firmware on both. I used the OTA steps however I did a factory reset on my box prior to flashing the firmware. Those that are experiencing issues may not have gone through the proper steps to properly flash the firmware.

              Again, thank you for your hard work.

              Comment


            • Easiest way to remove root?

              Comment


            • Originally posted by dolarrr View Post
              With this rom this box is almost perfect. No lags, Netflix, Youtube, simple games for kids.
              I'm not running this ROM yet, can you check what Version number Youtube is under Settings/Apps?
              Also, when you watch Youtube in fullscreen, does the TOP notification bar auto-hide...or does it always stay on?
              Thanks.

              Comment


              • Magendanz
                Magendanz commented
                Editing a comment
                Actually, the notification bar is hidden all the time on Android TV builds. You might want to check on non-ATV (Nano and Stock variants), though. Apps can hide both navigation and notification (a.k.a. status) bars if they choose.

            • Originally posted by legnosecco View Post

              I'm not running this ROM yet, can you check what Version number Youtube is under Settings/Apps?
              Also, when you watch Youtube in fullscreen, does the TOP notification bar auto-hide...or does it always stay on?
              Thanks.
              There is a new YouTube for Android TV version you can download from apkmirror. It was uploaded earlier this month.

              Comment


              • Originally posted by Karce View Post
                I registered just to say a big Thank You to Magendanz. This firmware has made this box a thousand times better than the original firmware. I've got 2 boxes and flashed the firmware on both. I used the OTA steps however I did a factory reset on my box prior to flashing the firmware. Those that are experiencing issues may not have gone through the proper steps to properly flash the firmware.

                Again, thank you for your hard work.
                I should mention that I did have an issue with one of the boxes freezing up on me occasionally....i reflashed using the USB burn tool and that box no longer freezes. I was lucky to have a male-to-male USB type A cable laying around

                Thanks again

                Comment


                • Magendanz
                  Magendanz commented
                  Editing a comment
                  I would say that 90% of the issues I see deal with people installing the OTA update without first checking the box to do a data wipe. That's built into the USB Burning Tool flash process, so you can't forget.

              • Originally posted by legnosecco View Post

                I'm not running this ROM yet, can you check what Version number Youtube is under Settings/Apps?
                Also, when you watch Youtube in fullscreen, does the TOP notification bar auto-hide...or does it always stay on?
                Thanks.


                Mine is showing ATV YouTube Version 2.00.19
                and
                there is an Update available in the Play Store 2.01.04

                Comment


                • First of all, thanks Magendanz for your hard work on this ROM!
                  This morning I flashed my M8S Pro+ (S905x) with USB Burn. Worked great, while trying to set it up. But after installing SPMC and FTMC trying to get frame rate switching working, it started to crash and randomly reboot. So I reburned the image to see if I corrupted something. But even on the clean image it would crash and reboot almost instantaniously. (Shortly after showing launcher, crash messages refer to random Android processes).
                  So just to make sure there is no problem with the hardware I burned the OEM image (M8S_PRO+-NMF26Q-20170815.182813.V0321.img). But still crashes and reboots.
                  Is it safe to say I'm dealing with a hardware issue?

                  Thanks!

                  Comment


                  • Magendanz
                    Magendanz commented
                    Editing a comment
                    There might be an issue with the 20170815 OEM firmware release, upon which this custom ROM was also built. Have you tried rolling back to the 20170730 release? (This was available only as an OTA update, so install in TWRP and don't forget to do a Wipe first) https://1drv.ms/u/s!AoqocX31ecnXgZ0C0X-jM77e3x1oyQ

                • Amazon Prime: thought I'd point out that if you have Amazon Prime, you can install Amazon Webview and Chrome (via Aptoide, in my case), log into Amazon via Chrome, select a show to stream and your reward will be Prime Videos in HD.

                  NB: be sure to set Chrome to "request desktop site" from its settings. When your video starts to load (spinning circle), let it do so for a bit then click near the top right of the black screen and you'll be able to select full screen video. The stream takes a minute to ramp up, but when it does it can reach 1080p and stay there for the duration.
                  Last edited by Zahir; 09-14-2017, 11:07.

                  Comment


                  • Originally posted by Zahir View Post
                    Amazon Prime: thought I'd point out that if you have Amazon Prime, you can install Amazon Webview and Chrome (via Aptoide, in my case), log into Amazon via Chrome, select a show to stream and your reward will be Prime Videos in HD.
                    Thanks for the info



                    Just confirmed my ATV Netflix 2.00.19 streams in HD and DD5.1


                    Pete

                    Comment


                    • Originally posted by abbots View Post
                      I've got the Mecool box, initially I've used the update function to flash 25/8 TV ROM from here, device worked well, was able to install apps, etc.
                      after few days device started freezing, whilst idle, whilst booting, whilst loading, became useless, even froze with Android circles bootlogo screen.
                      Today tried flashing both factory image, and, TV ROM image, though still have probs, at one point, box froze with Mecool blue screen on boot.
                      Have I got a bad one?
                      What options in Burn tool to use?

                      I had:
                      erase flash TICK erase all
                      (force erase??)
                      erase bootloader
                      reset
                      overwrite key NO

                      Thanks for any pointers and suggestions, thanks for the ROM

                      [22:12:38 024][HUB5-4][Inf]--Device is removed
                      [22:12:38 051][HUB5-4][Inf]--[0x00000000]Burning successfully
                      [22:12:38 051][HUB5-4][Inf]--Close device handle 0x000003b8
                      [22:17:43 261][Global][War]--User click stop button
                      [22:17:43 262][Global][Inf]--Enable burning 0

                      M8S_PRO+-NMF26Q-20170815.182813.V0321
                      M8S_PRO+-V0321_TVStock-20170825
                      Originally posted by abbots View Post
                      my Mecool unit worked fine for 1 week with ATV ROM but, now started locking up, even on boot, freezes often (not always) on splash screen or Android dots

                      tried reflashing with USB BurnTool 2.08 with either M8S_PRO+-NMF26Q-20170815.182813.V0321 or M8S_PRO+-V0321_TVStock-20170825 BUT, on power up keeps freezing

                      Burn Tool shows OK, no errors

                      am I doing something wrong ? what else can I do ? have I got a bad unit...?
                      I just reread this thread to find out if I am doing something wrong, since my box keeps crashing. (see post 297) Seems that I'm not the only one experiencing this problem. abbots describes the exact same problem I have.
                      Just swapped the power adapter for another 5V 2A unit from my other S905 box (running Libreelec). Still crashing.
                      Any suggestions for things to try, or just bad boxes?

                      Thanks again

                      Comment


                      • Magendanz
                        Magendanz commented
                        Editing a comment
                        There might be an issue with the 20170815 OEM firmware release, upon which this custom ROM was built. Have you tried rolling back to the 20170730 release? (This was available only as an OTA update, so install in TWRP and don't forget to do a Wipe first) https://1drv.ms/u/s!AoqocX31ecnXgZ0C0X-jM77e3x1oyQ
                    Working...
                    X