Announcement

Collapse
No announcement yet.

[ROM] AlfaWise H96 PRO+ 3/32 and 3/16 - SCV2 ROM (DDR3 ONLY)

Collapse
This is a sticky topic.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • [ROM] AlfaWise H96 PRO+ 3/32 and 3/16 - SCV2 ROM (DDR3 ONLY)

    Hi there guys and girls, one more rom/fw for you all!
    Many thks to gearbest for sending me the device to play
    Many Thks to my beta tester trebor

    Changelog V2:
    • Brand new rom, not stock anymore
    • Fixed power on from full shutdown with the IR Remote on some boxes!
    • Added TWRP
    • Fixed adb
    • Ported some stuff from Ugoos rom(thks Ugoos for their work)
    • Ported stuff include: Samba server, root/unroot(default unrooted), temp, ram, cpu usage etc.. monitor.
    • By default the rom is not rooted, so if yo want root enable it in settings.
    • Power Menu also ported from Ugoos!
    • PS3/PS4 gamepad support(only with cable...)
    • Fixed Xbox360 gamepad that showed power menu on dpad left, so no need to xposed fix!
    • RGB fix now its on the "stock" android settings(Display)... Can also use the app included.
    • New App that controls Brightness and contrast on the fly, and also apply's the rgb fix, cec fix and the saved brightness value on boot! IT NEEDS ROOT TO WORK.. (Many thanks to catharsys for the app )
    • Gapps updated!
    • Only 2 launchers (Launcher3 and Lighthome)...
    • Fixed a google framework crash.
    • Long Press Menu button hide/show upper/bottom bar
    • On the IR remote press "Setup"(red) button and it brings APP SWITCH...
    • Updated supersu app so no need to be updated from playstore to update "su" binary.
    • Some other stuff i cant really remember anymore.... lol
    • And many thks to trebor for the beta testing
    Bugs V2:
    • My Proper RGB FIX you need to flash this RGB FIX by recovery, you will after this experience some power off problems(it take some tries to fully power off...) and sleep led problem!
    • Only update "su" if you are going to to stay at root if are not going to stay at root and you are going to be doing a lot of changes between the two dont update it! Or you will get a boot animation loop...
    • On Mx Player disable in the settings the "Playback settings/ HDMI self-adaption", or else you may(or not) experience some screen going black(but i think this is more a tv problem than a rom problem...)
    • You may loose sound when enable my rgb fix on my kernel only (disconnect the hdmi cable and connect it again to solve it)
    • Miracast only work if the box its connected to a N wifi network(it wont work on AC) and in Miracast setting change to SD resolution, and it should work but sometimes takes some tries.
    • Ugoos Firefly only works on their kernel...
    Changelog V1:
    • MIx of stock and new stuff.
    • Netflix, youtubeTV playstore...etc... fully working
    • Xbox360 wireless Gamepad, original and Chinese clones?!(well it works with my clone adapter...)
    • New Launcher.
    • Miracast working (check bugs below for how to make it work)
    • CPU/GPU temperature should be a lot better now!
    • Proper rooted.
    • Added CEC fix for remote control not working after power off/power on (sleep mode also) (Many thanks to catharsys for the debug and fix)
    • RGB Fix in settings
    • Working Screen Rotation in settings.
    • FTMC 16.1 Build 21
    • initd.d support.
    • Network tweaks. (On N networks bw around 30 to 44mbits, and on AC networks from 200 to 230mbits on cable well... from 500mbits to 948mbits) i have a 1Gb/100mbit connection!
    • Permissions fixed.
    • Sleep working, full poweroff also working.. but not the power on from full shutdown with the IR remote!
    • Kodi Brightness fix (videos...)
    • Brightness fix for the system, if you guys want more or less brightness simple go to "/system/etc/init.d" and edit the file "1brfix" and change the value in here (echo "10") save and on the next boot you have the value you put it. A small bug, the 1º time the box boots after flash, its not working it only start working after 1º reboot/shutdown.
    • Removed background logging.
    • CEC disabled by default.
    • Fixed auto frame switch in kodi. It only works on FTMC(included) SPMC 16.5.5, on kodi 16.1 doesn't work because is to old(misses a lot of fixes for the new S9xx devices), Kodi 17 its a it and miss this days!
    • Gapps Updated!
    • Added Xposed Framework
    • Other small fixes and optimizations!
    Bugs:
    • Power On from full shutdown not working with the remote
    • Home in setting to change the default launcher it crashes, use pop up for now!
    • Miracast only work if the box its connected to a N wifi network(it wont work on AC) and in Miracast setting change to SD resolution, and it should work but sometimes takes some tries.
    Want to buy me a beer?Download:Install instructions:
    • Use usb burning tool....
    • Watch out this box have 2 hidden usb ports and the OTG port or is the one near the power plug or the one near the ETH plug but that one is hidden....
    Where to buy:1º BOOT TAKES AROUND 6 MINUTES!

    THIS ROM DELETES ALL YOUR DATA SO DO A BACKUP!


    USE AT YOUR OWN RISK!

    Enjoy it!
    Last edited by superceleron; 04-28-2017, 07:25.

  • #2
    RESERVED

    Comment


    • #3
      Thanks, been waiting for this one. Cheers!

      ::EDIT: Flashed with micro SD card and all working well!
      Last edited by lyricidal; 01-22-2017, 09:16.

      Comment


      • #4
        Heya,
        @ superceleron, Thanks much for investing your time. The box sucked with factory firmwares.....(really horrible Alfawise)
        FYI, Flashed 100% ok. Hooked up to 4K t.v....install android screen did not change for 20 mins.
        I pulled power and let reboot. Woot, nice fancy Freaktab boot screen. 6 mins later up and running.
        .
        A question about HDMI-CEC. When I switch to another device..this China box goes into sleep mode. Any way to prevent this? (CEC off ?, 4K Vizio t.v.) (Edit..fixed by Enabling CEC... )

        Thanks,
        Reap
        Last edited by ReaperMan; 01-21-2017, 21:11.

        Comment


        • #5
          An update... first box flashed...second box refuses (0x10105002)Romcode/initialze... @2 %. For what it's worth...second box is recognized and (more) quickley starts to erase then fails??

          Reap

          Comment


          • #6
            Originally posted by superceleron View Post
            RESERVED
            This firmware will work on X92 Ram 3gb/ Rom 16gb?

            Comment


            • #7
              Originally posted by ReaperMan View Post
              An update... first box flashed...second box refuses (0x10105002)Romcode/initialze... @2 %. For what it's worth...second box is recognized and (more) quickley starts to erase then fails??

              Reap
              weird... try another usb port on your pc.. this devices are picky,,, lol[

              Originally posted by karaganda72 View Post

              This firmware will work on X92 Ram 3gb/ Rom 16gb?
              Dunno m8

              Comment


              • #8
                Originally posted by ReaperMan View Post
                An update... first box flashed...second box refuses (0x10105002)Romcode/initialze... @2 %. For what it's worth...second box is recognized and (more) quickley starts to erase then fails??

                Reap
                I highly recommend the micro sd card method if you can do that. Updated a number of times today using it.

                Also, wasn't huge fan of the new launcher look so I repacked it with old icons and background colours from AmlLauncher_canzone.apk. Retained the FreakTab logo of course! Great job! (The old AmlLauncher_canzone.apk would not work so did it this way). I hope this is OK superceleron. If not I will remove immediately.


                AmlLauncher_lihai.apk (old icons/wallpaper w/ FreakTab logo) - https://mega.nz/#!TYkxmD7D!YpjFLkaCj...4XVTFp1ciYaW28

                Place file in system/app/AmlLauncher_lihai/ replacing the old one. Reboot.
                If that doesn't work, remove original "MediaBox Launcher" using a system app uninstaller. Replace file as above. Reboot.

                Comment


                • #9
                  Originally posted by superceleron View Post




                  Dunno m8
                  You made a universal firmware for 2/16,but you can make a universal for 3/16?

                  Comment


                  • #10
                    This one should work for 3/16 as well

                    or if you mean for 2/16, have a look here: http://freaktab.com/forum/tv-player-...on-beta-v5-rom

                    Comment


                    • #11
                      Heya,
                      Not sure what to try next. I've flashed twice with success, but, this second box is seen by burn tool but fails repeatedly at @2%. Tried 2.05 and 2.0.7? ..it is recognized and fails... 3 usb ports.
                      I have used Bootcardmaker 1.01 and 2.02?. (Maybe incorrectly.) Open Bootcardmaker, select format erase. Select provided uboot.bin. Finish..and copy over H96 Pro+ firmware.
                      Install microsd in device and boot hold/releasing reset pin.
                      Failed can't mount E/ .... tried load from external ((also had usb key with image) 3rd or 4th time). Can see other folders on usb ..but can't see/select h96.img file.
                      Am I using bootmaker incorrectly?

                      Any help appreciated,
                      Reap

                      Comment


                      • #12
                        In Boot Card maker do u mean u are selecting the .img file posted here?

                        Comment


                        • #13
                          Yes? Boot card maker says success, then copy image to microsd.
                          Any way to convert or install this update from within Android update tool?
                          Reap

                          Comment


                          • #14
                            Slt,


                            Originally posted by Valek View Post "merci à lui"

                            Install firmware with a microSD card

                            STEP 1 (download and extract).
                            Download :

                            Burn Card Maker and firmware

                            Extract "TF.rar" and firmware in the same folder.
                            Now you get "Burn_Card_Maker.exe" and firmware file.


                            Rename le firmware update.img

                            Put a microSD card in your computer (on Windows) and go to the second step.

                            STEP 2 ("make" the microSD card)
                            Run "Burn_Car_Maker.exe"
                            The first time it's in chinese, click on the top lef menu, click on the second option, check "English" and put "OK".
                            Close and restart "Burn_Car_Maker.exe"
                            Chose disk: (Letter of your microSD card)
                            "YES" must be check 3 times for "To Partition and Format", "erase_flash" and "Reboot" (erase_bootloader must be uncheck).
                            Click on "Open" and chose firmware img.
                            Click on "Make", format the microSD card (default settings), after that the rom copy begin on the microSD card, when it's done you get a "Success" message.

                            STEP 3 (installation)
                            Now, insert the microSD card in the device (power supply unplug/off).
                            Let your TV on and the HDMI cable plugged.
                            With a paper clip or other, press the reset button and hold it (small hole under the box), in the same time plug the power supply on the Beelink GT1.

                            Cdt,

                            Comment


                            • #15
                              Heya,
                              Thanks for the info..learned something new. It did flash and after the bar finished it shut down? I get a blue light in the box but no signal on hdmi...possible bricked.
                              Will/might try again tomorrow.

                              Thanks
                              Reap

                              Comment

                              Working...
                              X