Announcement

Collapse
No announcement yet.

Mecool M8S PRO L - Ethernet connection problem

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Mecool M8S PRO L - Ethernet connection problem

    I really can't find anyone talking about an issue with the ethernet connection, maybe I'm the only unlucky one.

    I'm using the new version (bought April 2018) of the Mecool M8S PRO L that comes with Bluetooth voice remote and Leanback launcher (LB hardware version).

    The ethernet connection is almost impossible to keep connected (wi-fi works just fine).

    1. If I power up the box with the ethernet wire connected in the socket, then it won't establish connection.
    2. Instead, I need to physically pull out the wire and re-insert it, and then the box becomes connected.
    3. But it stays connected until I power down. If I power down and on again, connection is lost, until again I physically remove and re-insert the ethernet wire.

    Anyone facing such a problem? Is it 100% faulty hardware, or it might be software/firmware/settings problems?
    (by the way I tried this with many different ethernet wires)

    Thanks everyone and anyone!

    #2
    Hi did you ever get the issue with ethernet vfixed?

    Comment


      #3
      Yes, i should have updated the thread before.

      It seems my box’s ethernet was sort of incompatible with certain routers.

      The problem Occured when connecting the box to a Linksys router, or a Netgear hub.

      Problem was solved when connected to an Asus router, or a Linksys hub

      Comment

      Working...
      X