Announcement

Collapse
No announcement yet.

MECOOL M8S PRO TV Box Amlogic 912 Android 7.1 3/16GB Dual WiFi Fast Lan BT4.1

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #76
    Hi, Would the OTA firmware for the M8S Pro work on the KB2 Pro (3GB DDR4 / 32GB) ? they appear identical hardware wise and are both made by the same company (i.e Videostrong).

    Not sure why KB2 Pro is still on Marshmallow whilst the M8S Pro is on Nougat but would be good to upgrade to Nougat.

    Thanks in advance

    Shaun

    Comment


    • #77
      Originally posted by eddiepropane View Post
      Couldn't find this thread after the forum change so made a new one in the MECOOL/VORKE thread but just in case:

      Hi,

      A USB IMG has now been uploaded for the M8S PRO:

      M8S_PRO-NMF26Q-20170524.163713.V0321.img

      https://pan.baidu.com/s/1slc109B

      I am currently downloading

      Was offline most of yesterday but here you go:

      HTML Code:
      https://mega.nz/#!cSxTUTzB!o8g7nWbEBBSDi67GmPTWz9FJZS6oAZzHjbO1jZ3G-Lg
      Cheers, Bob.
      I am new in here. My box build is M8S PRO NMF26Q 20170505.084815.V0222. I downloaded the update firmware M8S PRO NMF26Q 20170524.163713.V0321.img.
      I tried the OTA update but the box couldn't find the update firmware. Therefore I wish to update through local USB. Will you please advise how to update my box with the new firmware(.img)?
      Any tools or instructions to follow so that my box will be upgraded to the new firmware? Thank you.

      Comment


      • #78
        Originally posted by ralphc View Post

        I am new in here. My box build is M8S PRO NMF26Q 20170505.084815.V0222. I downloaded the update firmware M8S PRO NMF26Q 20170524.163713.V0321.img.
        I tried the OTA update but the box couldn't find the update firmware. Therefore I wish to update through local USB. Will you please advise how to update my box with the new firmware(.img)?
        Any tools or instructions to follow so that my box will be upgraded to the new firmware? Thank you.
        When you downloaded, do you have a single zip file?

        If yes, unpack the zip file and there should be 3 files (factory update, m8spro ota zip file and recover image - Note of these 3 unpacked files do not extract this zip file)

        Copy the 3 unpacked zip files to the root directory of a clean micro SD card.

        Insert the micro sd card into the M8s Pro sd card slot and navigate to open the update apk

        Open local update and select the location of the sd card, select the zip file displayed and press update.

        Leave it to update until the update is completed.

        I have recently done it like this, but as always please read and proceed carefully and you do this at your own risk.

        Comment


        • #79
          Thank you Comeandgetme. My download(from eddiepropane) has one .img file only. What should I do? In the mean time, Is there any method to backup existing data before doing the update?

          Comment


          • #80
            Originally posted by ralphc View Post
            Thank you Comeandgetme. My download(from eddiepropane) has one .img file only. What should I do? In the mean time, Is there any method to backup existing data before doing the update?
            Download the zip from post #65
            https://yadi.sk/d/BsZXPQua3Jo4st
            Copy the "M8S_PRO-ota-20170524.163713.V0321.zip" file as is (do not uppack) onto a clean Micro SD card.
            Use the OTA updater app to flash firmware.

            To Backup your data, copy files to a USB disk using "ES File Explorer" or something similar from the play store. But the firmware update does not erase your Android STB unless you tick the factory & cache reset options.

            Be aware that there are a few issues with the 2017-05-24 update though. Have a look at Posts #70 ~ #73...

            Good luck.

            Comment


            • #81
              Thank you aspittles. I've upgraded to 20170524 firmware smoothly without any data lost.

              Thank you again to aspittles and also comeandgetme.

              Comment


              • #82
                Hi guys,
                I have one of these MECOOL M8S Pro 3 /16 Rom. I have issues with the device unable to play some of my streaming apps (The errors say that the device is rooted, even though it isn't), I am thinking of flashing the device with a Android 6 (Marshmallow) or even to 5 to get around the security issues. Has anybody either rooted this device, or know of a rom I could try?
                Thanks
                Leon (South Africa)

                Comment


                • #83
                  HI mohA2B,
                  Have you managed the root?

                  Comment


                  • #84
                    Check out the post just above which relates to a 5/24 dated rom. Used this one and is not rooted. Works fine for me. It updates to android 7.1.1 Seems to work fine. Tried both roms and they work fine. The 5/24 rom works fine if you can live with the quirks of 7.1.1

                    Comment


                    • #85
                      Originally posted by LeonNel76 View Post
                      HI mohA2B,
                      Have you managed the root?
                      There is a youtube video. Search Mecool M8S Pro root.

                      Comment


                      • #86
                        I got this device (3gb/32gb version) a couple of days back (ordered from Banggood). The device gets stuck on MECOOL boot up image every 2 out of 3 times I reboot it. This happens even when the device isn't excessively hot right after I turn it on for the first time and I believe has something to do with the firmware. The version of the firmware the device came in was dated 05-05-2017 and the issue started before I installed any additional applications. When the device boots up fine it works with no issues. Any idea if it's a hardware issue and I have to go through the hassle of returning the unit back? The other issue I noticed which is likely hardware is that as soon as I plugin the HDMI cable when the device is powered on my subwoofer starts emitting constant low hum sound. When I unplug the cable the hum disappears. Not sure if anyone noticed similar issue with their units.

                        Comment


                        • #87
                          Hi ! Someone have video problem? Sometimes the video is green/purple , I know this problem because I have same problem with nexbox a95x with amlogic s905x , I think amlogic s912 don't have this problem ,but maybe I'm wrong....

                          Comment


                          • #88
                            I do update at the last firmware of 24/5 , the green/purple issue is better but not completely fix sometimes come back

                            Comment


                            • #89
                              OK i nave the most incredible problem and I swear of god I'm not trolling, please believe me guys.
                              A few days ago I bought this android box (52 euro from Gearbest). The box itself is all right, when works...
                              But almost right after I started using it, maybe a couple of days, a problem showed up.
                              Basically, every time I turned on the android box, my router goes "crazy", all LEDs are led and no device in the house can't connect to my connection anymore. I have to turn off the box, restart the router and then everything is OK again. After a little research in other forum, people suggest it was a problem of IP addresses, should I set an IP static just for the box, etc etc...? Actually that's what I thought too. So I was playing a little bit with the IP settings when I found out something absurd:
                              The android box is able to mess my router EVEN WHEN HIS WIFI IS OFF! Yes, it doesn't even have to try to cconnect...just turning it on near the router is enough to mess with it! I thought " what kind of emp / radio signal / vodoo waves this thing has?!?!
                              Worried about my health (I sleep in the same room where box and router are) I just kept the android box off since then...I wrote to Gearbest but they still don't unswer.
                              What do u think guys?
                              I leave u with a self explicatory video : https://youtu.be/HTUwB1J-raw
                              ​​​​

                              Comment


                              • #90
                                Originally posted by Lightcycles View Post
                                I got this device (3gb/32gb version) a couple of days back (ordered from Banggood). The device gets stuck on MECOOL boot up image every 2 out of 3 times I reboot it. This happens even when the device isn't excessively hot right after I turn it on for the first time and I believe has something to do with the firmware. The version of the firmware the device came in was dated 05-05-2017 and the issue started before I installed any additional applications. When the device boots up fine it works with no issues. Any idea if it's a hardware issue and I have to go through the hassle of returning the unit back? The other issue I noticed which is likely hardware is that as soon as I plugin the HDMI cable when the device is powered on my subwoofer starts emitting constant low hum sound. When I unplug the cable the hum disappears. Not sure if anyone noticed similar issue with their units.
                                Hi!
                                I'm having the same problem with the freezes/stuck on booting! it sucks a LOT

                                Comment

                                Working...
                                X