Announcement

Collapse
No announcement yet.

[ROM] Khadas Vim 2 - SCV3-ATV Beta (AndroidTV)

Collapse
This is a sticky topic.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • [ROM] Khadas Vim 2 - SCV3-ATV Beta (AndroidTV)

    Here is the ATV version
    Many thks to gearbest for sending me the device to play
    Thks trebor for the beta test!

    READ THE BUGS SECTION FOR UNNECESSARY QUESTIONS!!!!

    UPDATE LIKE THIS - SCV1 (IMG) -> SCV3 (OTA) (ALL OTHERS THAT ARE ON OTHER VERSIONS YOU CAN UPDATE JUST FINE )


    Changelog V3:
    • Fixed passthrough in Kodi 17, SPMC 17, FTMC 17, maybe others... (DTS, DTS-HD etc...)
    • Updated Youtube APP to 2.01.04
    • Some video optimizations ( tested in two different's online ISP's TV and both give HD streams just fine )
    • Other little stuff...
    Bugs V3:
    • Same as V1


    Changelog V2:
    • Fixed fan not starting after reboot!
    • Fixed gamepads keys
    • Enabled multiuser.
    • Other little stuff done... crash fixes etc..
    Bugs V2:
    • Same as V1


    Changelog V1A:
    • Fixed a nasty(my fault lol) AMCODEC bug in FTMC Krypton(to be rls) and SPMC krypton(is NOT the 16.8rc1..) and possible others.
    • Turn on the fan by default, in auto sense mode!
    Bugs V1A:
    • Same as V1


    Changelog V1ATV:
    • 55% based on stock +/-
    • Big optimization, is really fast now and i mean fast... you will see it!
    • Navigation should be smooth as silk and fast.
    • New Boot Logo, many thks to danielelek90 for the great work
    • Netflix, youtube, playstore...etc... fully working
    • 4k Youtube support.
    • initd.d support.
    • PS3/PS4 gamepad support ( only with cable... )
    • Added Xbox360/XboxOne gamepad support ( cable, wireless and Bluetooth )
    • Added Dragonrise USB HID game controllers.
    • Removed Navigation and Status bar just like Real ATV's. ( so dont ask for it )
    • Wifi connection speed should be a little better.
    • Permissions fixed. ( lots... )
    • Many KL's added.
    • Fixed AMCODEC playback.
    • Some audio mods.
    • FTMC Build 30
    • Optimized some animation stuff!
    • And a lot of other stuff that i dont remember now! ( ye ye i know i need to make notes... )
    • And of course all the other ATV mambo jambo LOL
    Bugs V1ATV:
    • On setupwizard dont choose tablet to login, choose normal login since the table/etc.. is not working.
    • On "More Settings" in settings you will see the white settings, forget it... it wont work it will crash if you press anywhere, real atv dont have that settings.
    • Removed superuser app to avoid bootloop's if anyone by mistake updates the su binary....
    • No TWRP for now, im having some weird issues with it... so that is going to take more time... sorry no Magisk install of course because of that.
    • Possible a lot more!


    Want to buy me a beer?

    Download SCV3 Cumulative OTA:
    Download SCV1 IMG:

    Install instructions:
    • Use usb burning tool.... to flash the IMG...
    • Use recovery to flash the OTA....


    Where to buy:

    1º BOOT MAY TAKE +/- 6 MINUTES!

    THIS ROM DELETES ALL YOUR DATA SO DO A BACKUP!


    USE AT YOUR OWN RISK!

    Enjoy it!
    Last edited by superceleron; 09-07-2017, 16:42.

  • #2
    Updated 1º post with SCV1A OTA

    Comment


    • #3
      Updated 1º post with SCV2 OTA

      Comment


      • #4
        Originally posted by superceleron View Post
        Here is the ATV version
        ...
        On "More Settings" in settings you will see the white settings, forget it... it wont work it will crash if you press anywhere, real atv dont have that settings.
        For this issue apply attached patch to frameworks/base.

        I don't have Vim2 but it was issue for me too on Nougat. Question. Which atv gapps you use?
        Attached Files
        If you find my work useful, buy me a beer
        Homepage: http://www.stane1983.com

        Comment


        • #5
          Originally posted by stane1983 View Post

          For this issue apply attached patch to frameworks/base.

          I don't have Vim2 but it was issue for me too on Nougat. Question. Which atv gapps you use?
          Thks stane for the fix, now i only need to wait for them to rls the source for the vim2, or did they already did it?
          About gapps, i use a mixed gaps.
          Is Opengapps with some changes because if you use as it is some stuff dont work as expected!
          For example SetupWraith if you use the included in opengapps it always crash in the end of the setup, and others like some need to be signed with the platform key etc.. so is a mix custom gaps +/-.

          Comment


          • #6
            Now thinking on it... i need to rls a fixed build today... Kodi17, SPMC17, FTMC17 passthrough dts-hd etc etc... sound fix!

            Comment


            • #7
              Originally posted by superceleron View Post

              Thks stane for the fix, now i only need to wait for them to rls the source for the vim2, or did they already did it?
              About gapps, i use a mixed gaps.
              Is Opengapps with some changes because if you use as it is some stuff dont work as expected!
              For example SetupWraith if you use the included in opengapps it always crash in the end of the setup, and others like some need to be signed with the platform key etc.. so is a mix custom gaps +/-.
              Hi,

              I don't follow Khadas git, I have access to aml sources directly. About gapps, thats why I asked. I have SetupWraith crashing at end but resigning it didn't help. Also Play Store doesn't work (it logs in but refuses to download and install anything).
              If you find my work useful, buy me a beer
              Homepage: http://www.stane1983.com

              Comment


              • #8
                Originally posted by stane1983 View Post

                Hi,

                I don't follow Khadas git, I have access to aml sources directly. About gapps, thats why I asked. I have SetupWraith crashing at end but resigning it didn't help. Also Play Store doesn't work (it logs in but refuses to download and install anything).
                Well you can use the ones in mine they work just fine

                Comment


                • #9
                  Hi! Newbie here.. Managed to install the .img. Easy part! Now, how to proceed with the OTA? I used parameters/About/Update - local OTA. Then what?? I reboot and have the welcome wallpaper.
                  A more detailed explanation would be welcome here!
                  Thks for your help!!

                  Comment


                  • #10
                    Answer to myself (the newbie) : open the drawer app and launch the app for rebbot et select .. recovery. That was sooo difficult for my 2 beans running in my head!.

                    Comment


                    • #11
                      Originally posted by mascaret View Post
                      Answer to myself (the newbie) : open the drawer app and launch the app for rebbot et select .. recovery. That was sooo difficult for my 2 beans running in my head!.
                      see a little thinking gets you far
                      Glad you found the solution yourself

                      Comment


                      • #12
                        Originally posted by superceleron

                        Well you can use the ones in mine they work just fine
                        Yep, they do. Just a tip, hop to apkmirror and grab newer youtube app for atv

                        Only left in my sources to sort out is cast receiver. My devices see it but connection fails. Did not toy with it too much.

                        Sent from my ONEPLUS A3003 using Tapatalk

                        If you find my work useful, buy me a beer
                        Homepage: http://www.stane1983.com

                        Comment


                        • #13
                          Originally posted by stane1983 View Post
                          Yep, they do. Just a tip, hop to apkmirror and grab newer youtube app for atv

                          Only left in my sources to sort out is cast receiver. My devices see it but connection fails. Did not toy with it too much.

                          Sent from my ONEPLUS A3003 using Tapatalk
                          2.01.04?
                          Is already in this last OTA that i made (still to be posted, we are having some flie server problems... )

                          Comment


                          • #14
                            updated 1º post with SCV3 Cumulative OTA....

                            Comment


                            • #15
                              Just received my VIM2 max and will help testing and building ;-)

                              Comment

                              Working...
                              X