Announcement

Collapse
No announcement yet.

C96x 1G/8G S905x android 6.0 stock rom or stock recovery

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • C96x 1G/8G S905x android 6.0 stock rom or stock recovery

    Hi Folks,

    Foolish noob here looking for some help to get out of a hole i dug for myself!

    Does any one have one of these boxes and have or know where i can get stock ROM or stock recovery (or a non stock one that will help me).i cant find it on chinagagetreviews. This was my fist time tying to flash android and i have messed the box up some i think...

    I was having issues when i deleted old Kodi install as i now use SPMC 16, and wanted more space to test drive SPMC 17 alpha but the space did not show up after uninstalling kodi and manually deleting userdata folder, with internal storage staying close to full and preventing me installing SPMC17, there were several gb of thumbnails deleted from the kodi install so i was expecting this to become available again and allow me to install SPMC 17 side by side with 16. I did a factory re-set and space came back but i came to the conclusion issue likely would return and that probably a better FW was available so looked at custom ROM.

    i thought i found one but it turned out it was for wrong box. i flashed twrp using rashr but it couldn't mount my partitions so could not flash. i had backed up my oem recovery partition to SD but this got inadvertently wiped so i have no way back. my box still boots both in to twrp and also android so it is not bricked - yet! but the only thing i am able to flash at the moment is the recovery partition (i found a recoveryp212.image that i can also flash but this complains cant mount /misc or / cache/ and some other stuff so can't flash new ROM with that either and it doesn't do anything when i try factory reset and android boots to it).

    i was wanting to experiment with XTMOD_EX_P_28.img which is supposed to work with many p212 boards. my c96x box is 'spare' so was willing to take risk of bricking but obviously hoping not to brick, improve performance and my knowledge enough to try on my other android box's / tablets, that i really don't want to brick!

    additionally when flashing i seem to have broken USB-OTG. my box used to show on the PC in device manager while booting but after flashing it does not. twrp cant mount USB-OTG and i tried some tools in android to check it and it also doesn't find any USB-OTG so so a little stuck... it doesnt show on PC anymore regardless to boot state (recovery or normal) or weather i have twrp or recoveryp212.img as my recovery partition.

    i am hoping if i can get the stock recovery.img i can flash, do factory reset and be back to normal, with usb-otg working again then i can flash the custom rom with USB burning tool form my PC

    any help would be appreciated....

    Thanks
    Last edited by cubasekid; 09-26-2017, 03:09.

  • #2
    OK so i moved things on somewhat..

    i found the device was not being picked up on my PC due to power-saving on the USB ports, and my PC and laptop not being rebooted since my very first attempt, so explains why it was initially picked up then later not. As soon as i disabled this it was recognised and has been almost floorlesley since however, i could not get it in to recovery mode to flash.

    i followed this excellent guide to get the box flashing...

    http://freaktab.com/forum/tv-player-...-button-method

    however my device keeps failing to flash. it fails randomly with verify partition doing the sha1 hash check, clicking refresh gets past apart from when downloading 'system', this step continually fails the hash check, and counts the partition differently each time.

    i tried quite a few different roms for s905x but always the same. apart from one image that appeared to brick my box with PC no longer picking it up. i got past this by shorting two pins on my Skhynix nand and the PC picked it up again. i have tried flashing from XP, W7 and W10 but always the same, random errors on boot / recovery / logo hash checks that 'refresh' gets past then error verifying 'system' at the end that i just cant get past. i have used 2.05.15, 2.08 and 2.09 of USB burning tool but no help.

    i also tried altering the rom with the customisation tool, taking out the verify step for 'system' in image.cfg as described by Gekk in the below post, to get round same issue on different box. USB burning tool completes with my altered image but the box still wont boot.

    https://w3bsit3-dns.com/forum/index....c=723156&st=60

    i tried with SD and this also fails at different points, but the SD card is possibly the issue here as it intermittently fails in burn card maker and i have to create again.

    anyone have any clue to what may be the issue - is my box / nand messed up, poor quality USB cable or have i just been unlucky with all the roms i have tried so far and they are just incompatible with my box?

    i would have thought even if the rom was not good for my box, provided correct DDR / CPU type it would at least flash, but then not boot., or boot but with some things not working...

    any ideas on what I should be trying next to get the device flashed?

    Thanks!
    Last edited by cubasekid; 09-28-2017, 22:27.

    Comment


    • #3
      I know it's been awhile, but did you ever find a solution to your problem by chance? I'm able to flash/burn by connecting only the USB port closest to the HDMI port to my PC with a male to male USB cord and flashing XTMOD 3.0 using the force erase all method, but even though the flash succeeds, the device won't boot :/ It sucks not being able to find factory firmware, did you by chance come across it anywhere?

      Comment


      • #4
        Hi All,
        yesterday I failed to modify the initial bootvideo resulting in a device stuck at the end of booting.

        Since there were no restore possibility, no backup image and c96x support I looked for similar devices (in my case I have a 1GB RAM version).

        It turned out that c96x is very similar to m96x: and also the pcb of these device is almost the same.

        I succeded finding an image of m96x, uploaded into the box by "USB burning loader" and now the device is still working.

        Unfortunately the image that I found is a non rooted heavenly customizated by something called Memohi (infact the Android 6 OS is renamed into MEMOhi OS v.2). It is very limited but it is much better than a nonworking device.

        That's my experience. Hope it could be helpful for anyone.

        PS. You may find the mentioned rom here.

        Comment

        Working...
        X