Announcement

Collapse
No announcement yet.

Installing LibreElec on Beelink Mini MXIII II

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Installing LibreElec on Beelink Mini MXIII II

    I’m just dropping a note here about success in using LibreElec. I found it a little confusing in putting together the entire process to install LibreElec, however, in the end it is reasonably straight forward and definitely worth it.

    Keen to experiment with LibreElec, I sought out a S905 box and was fortunate to obtain a second hand Beelink MXIII-II that of course has the S905X chip.

    The main reasons I want LibreElec are:
    - Frame rate switching has limited support in Android 5+ and hence Kodi 17+
    - Looking for greater stability and slicker performance
    - Prolonging the life of AMLogic boxes, I have some S8xx boxes for which there are community builds of LibreElec.

    Here are the steps that I found worked for me. Note that once you get this working, updating to subsequent versions is a breeze (well allegedly, yet to do this). There is nothing new here, I have simply brought together a set of the steps that worked for the specific case of a Beelink MXIII-II from various websites and YouTube videos.

    1. Prepare your SD card

    I grabbed a Sandisk 16Gb micro SD card and popped it into my USB card reader plugged into my PC.

    Download ‘Rufus’ which is a formatting tool. It’s a single executable file that doesn’t need installing, just double click it to run.

    Download the LibreElec image for the version you wish to use. The bog standard version is the one that works. I used the gz image. The file name should look like: LibreElec-S905-ARM-x.xx.img.gz

    Download the device tree that matches the LibreElec version. The standard 2G version worked perfectly. The file name should look like: gxl_p212_2g.dtb. Rename this file to dtb.img

    Using Rufus, burn the image onto the SD card. In Rufus, select your SD card drive letter. Then 2/3rds down the screen there is a drop box to choose the boot system with a button next to it that allows you to select the LibreElec image - various options become greyed out which is all good. Click ‘Start’ and a green bar will show progress, although the last 0.3% seems disproportionately long!

    The SD disk is probably now labelled LIBREELEC and one partition is now visible, but there is no need to be worried about the so termed hidden partition. Copy your renamed dtb.img file over the top of the existing one in the root of the SD card.

    This is the hardest part, get this right. There should be no error messages etc.

    2. Boot the SD card in your Beelink MXIII-II

    Head to your TV area where hopefully your Beelink is connected (HDMI, power, maybe LAN cables). Take a toothpick with you, or I use a straightened plastic coated paper clip.

    Insert the micro SD card. It goes in ‘upside down’, with the connectors upwards. It goes all the way in before the click is felt, use your fingernail... don’t worry you won’t lose it inside the box.

    Now unplug the power. Turn the Beelink box upside down placing it flat on its back. There’s a little hole toward a corner. Poke your toothpick slowly and straight into the hole. The button is about 5mm inside so keep moving until you strike the button. Practice clicking it a few times so you know for sure you’ve got it.

    Ok time to do it for real. Making sure you can see the screen. Press down your toothpick and click and hold the button with one hand and plug in power with the other and watch the screen. After literally a few seconds you should see the LibreElec logo and you can now remove the toothpick.

    That really should be it, Kodi should come up on the screen and you enter the preliminary configuration of your network. Make sure you turn both SSH and SMB services on, they both can come in useful for upgrading, transferring to the internal memory etc.

    (Optional) 3. Transfer to internal memory

    The read write speeds of your internal memory are likely to be faster than the micro SD card. Many people seem to report and increased responsiveness when LibreElec is running from the internal memory. This means that you will not be able to run Android with a full reinstallation of appropriate firmware. Hence think carefully before doing this. In the end I think it is just a preference as the marginal benefit would not outweigh the ability to have a dual purposed box.

    This wasn’t an issue for me with this ‘experimental’ box so what the hell, I went for it! I needed to do this twice before all worked properly. A number of people have reported this and each time it works after a second install. It appears to be an issue with the partition layout You’ll need your toothpick again.

    First download the program Putty that enables access to your box using SSH (which must be enabled for this to work). This is again a single executable file that you simply double click to run. Look up your Kodi IP address in System Info. You enter this address into the GUI in the Host Name box and click Open.

    This opens a shell with a prompt. The user is ‘root’ and password ‘libreelec’ and you’ll be logged in. Type ‘installtointernal’ and Enter. You will get a few prompts such as Do you really want to do this? (Always confidence building) and Do you want to transfer user data? Which you most likely do wish to.

    When you get to the request to reboot, do this. Your session is terminated, all good. Go back to your box. You will probably see a corrupt file system message on the screen. Pull the power, flip the box over and toothpick the button, plugging back in the power. Let off when you see the LibreElec logo and you’ve booted back into the SD card so all will be working.

    Back to your PC, Putty in again, execute ‘installtointernal’, this time rebooting should see LibreElec working just fine.


    I hope some find this useful. I am sorry if it does not go as per the above plan for you.
Working...
X