Announcement

Collapse
No announcement yet.

LibreELEC 4k stutter

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • LibreELEC 4k stutter

    Hello,

    I recently installed LibreELEC 8.0.1g running kodi 17.1and all is working well, except for 4k media streamed locally from my server which barely plays at all... I am running on an m8s mini II via ethernet, but this particular box only supports 100mb and I suspect adjusting the cache settings may rectify things.

    My question is; where on earth do I put the advancedsettings.xml file on this particular build of kodi? The route is supposed to be '/storage/.kodi/userdata' but I don't have a '.kodi' folder in storage at all... If I open file manager then click profile directory I get taken to 'special://profile' which contains some of the other xml files (mediasources, rssfeeds etc) that I would expect to see so I have tried to copy advancedsettings.xml into this folder but it doesn't seem to have changed the buffer at all (ram usage still reported the same).

    N.B. I've used the updated Krypton cues for the xml file as follows:

    <cache>
    <memorysize>314572800</memorysize> <!-- number of bytes used for buffering streams in memory
    When set to 0 the cache will be written to disk instead of RAM -->
    <buffermode>1</buffermode> <!-- Choose what to buffer:
    0) Buffer all internet filesystems (like "2" but additionally also ftp, webdav, etc.) (default)
    1) Buffer all filesystems (including local)
    2) Only buffer true internet filesystems (streams) (http, etc.)
    3) No buffer -->
    <readfactor>4.0</readfactor> <!-- this factor determines the max readrate in terms of readbufferfactor * avg bitrate of a video file.
    This can help on bad connections to keep the cache filled. It will also greatly speed up buffering. Default value 4.0. -->
    </cache>

    Any help anyone can offer is greatly appreciated!

    Thanks all

  • #2
    Right I'm a tit and have now found the .kodi file having turned on 'view hidden files' under settings, however whatever value I put in the buffer size line the stuttering continues and the system still reports the same 20% ram usage... Does anyone have any ideas how to rectify this please?

    Thanks all

    Comment

    Working...
    X