Announcement

Collapse
No announcement yet.

Unbrick MXQ-4K (R329Q_V3.0)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Unbrick MXQ-4K (R329Q_V3.0)

    Hello, sorry for my english. I'm have a question, how to unbrick my device? I tried installing a custom rom and the process failed in "test device" then I canceled the process. So the device will not turn on, it will have red and blue LEDs light. In rockchip batch tool, when i connect the device with the OTG USB cable, the First Square Its BLUE, And in Android tool, show's me "Found one maskrom device".
    How to proceed? Thanks.

  • #2
    Hi ,

    that is simple , if Flashtool is started and the FW is loaded press restore and wait till it is finisched ,

    exit Flashtool , exit Box , connect to TV and set up your Box new , hopefully .

    please report , greetings / gefattern

    Comment


    • #3
      Originally posted by gefattern View Post
      Hi ,

      that is simple , if Flashtool is started and the FW is loaded press restore and wait till it is finisched ,

      exit Flashtool , exit Box , connect to TV and set up your Box new , hopefully .

      please report , greetings / gefattern
      Thanks for the quickly answer. I got "IDB fail"
      Greetings

      Comment


      • #4
        Originally posted by lucasgabiatti View Post

        Thanks for the quickly answer. I got "IDB fail"
        Greetings
        Hi ,

        take AndroidTool 2.35 , run as Admin , take second Tab , load FW , of course Box must connected , then "erase Flash" and wait till

        ready after that press "upgrade" wait till ready , same as before , now hopefully restore your Box on TV .

        greetings / gefattern

        Comment


        • #5
          Originally posted by gefattern View Post

          Hi ,

          take AndroidTool 2.35 , run as Admin , take second Tab , load FW , of course Box must connected , then "erase Flash" and wait till

          ready after that press "upgrade" wait till ready , same as before , now hopefully restore your Box on TV .

          greetings / gefattern
          Hello, i try this method, and got this:
          Can my usb otg cable just charging and not transfer data?
          thx

          Comment


          • #6
            Originally posted by lucasgabiatti View Post

            Hello, i try this method, and got this:
            Can my usb otg cable just charging and not transfer data?
            thx
            Hi ,

            please check on third Tab the Tests for IDB and others , the Offset must 1-4 Sectors so total 5 must shown ,

            Sector 0 , 1 , 2 , 3 , 4 , and check the Log files about Error Messages about IDB , maybe your IDB is bricked ???

            You are not sure to use the right USB Cable ??? if , use the one that came with the Box .

            Please upload or link the Rom that you used , to see in Tool , maybe you can help another User with it . Thanks

            greetings / gefattern

            Comment


            • #7
              What's the name of the rom you are trying to restore ?

              Comment


              • #8
                Originally posted by manu_manu4 View Post
                What's the name of the rom you are trying to restore ?
                A95X_R1_SSV6051P_complex_tvmc_change_100_ddr624_up datewifidriver_RK3229_6.0.1_201700704


                I follow this steps: https://www.youtube.com/watch?v=ogLAc2t_SIc&t=589s

                ROM link: https://mega.nz/#!NPZWnLIa!5ZAHEoTKh...XrS78YOtECMl-4

                Comment


                • #9
                  Originally posted by gefattern View Post

                  Hi ,

                  please check on third Tab the Tests for IDB and others , the Offset must 1-4 Sectors so total 5 must shown ,

                  Sector 0 , 1 , 2 , 3 , 4 , and check the Log files about Error Messages about IDB , maybe your IDB is bricked ???

                  You are not sure to use the right USB Cable ??? if , use the one that came with the Box .

                  Please upload or link the Rom that you used , to see in Tool , maybe you can help another User with it . Thanks

                  greetings / gefattern
                  10:53:55 070 AndroidTool v2.3.5.0 start run
                  10:54:31 186 Layer<2-1-3>Download Boot Start
                  10:54:33 414 Layer<2-1-3>Download Boot Success
                  10:54:33 421 Layer<2-1-3>:Wait For Maskrom Start
                  10:54:33 886 Layer<2-1-3>:Wait For Maskrom Success
                  10:54:33 895 Layer<2-1-3>:Test Device Start
                  10:54:33 903 Layer<2-1-3>:Test Device Success
                  10:54:33 911 Layer<2-1-3>:Get FlashInfo Start
                  10:54:33 918 <LAYER 2-1-3> INFO:FlashInfo: 00 00 00 00 00 04 04 00 28 00 00
                  10:54:33 926 Layer<2-1-3>:Get FlashInfo Success
                  10:54:33 935 Layer<2-1-3>:Prepare IDB Start
                  10:54:33 942 <LAYER 2-1-3> ERROR:PrepareIDB-->No Found 1st Flash CS
                  10:54:33 952 Error:Layer<2-1-3>:Prepare IDB Fail



                  10:54:15 980 Error:EnumerateHubPorts-->DeviceIoControl failed,err=0x48f



                  ROM Name: A95X_R1_SSV6051P_complex_tvmc_change_100_ddr624_up datewifidriver_RK3229_6.0.1_201700704


                  I follow this steps: https://www.youtube.com/watch?v=ogLAc2t_SIc&t=589s

                  ROM link: https://mega.nz/#!NPZWnLIa!5ZAHEoTKh...XrS78YOtECMl-4

                  Comment


                  • #10
                    Originally posted by lucasgabiatti View Post

                    10:53:55 070 AndroidTool v2.3.5.0 start run
                    10:54:31 186 Layer<2-1-3>Download Boot Start
                    10:54:33 414 Layer<2-1-3>Download Boot Success
                    10:54:33 421 Layer<2-1-3>:Wait For Maskrom Start
                    10:54:33 886 Layer<2-1-3>:Wait For Maskrom Success
                    10:54:33 895 Layer<2-1-3>:Test Device Start
                    10:54:33 903 Layer<2-1-3>:Test Device Success
                    10:54:33 911 Layer<2-1-3>:Get FlashInfo Start
                    10:54:33 918 <LAYER 2-1-3> INFO:FlashInfo: 00 00 00 00 00 04 04 00 28 00 00
                    10:54:33 926 Layer<2-1-3>:Get FlashInfo Success
                    10:54:33 935 Layer<2-1-3>:Prepare IDB Start
                    10:54:33 942 <LAYER 2-1-3> ERROR:PrepareIDB-->No Found 1st Flash CS
                    10:54:33 952 Error:Layer<2-1-3>:Prepare IDB Fail



                    10:54:15 980 Error:EnumerateHubPorts-->DeviceIoControl failed,err=0x48f



                    ROM Name: A95X_R1_SSV6051P_complex_tvmc_change_100_ddr624_up datewifidriver_RK3229_6.0.1_201700704


                    I follow this steps: https://www.youtube.com/watch?v=ogLAc2t_SIc&t=589s

                    ROM link: https://mega.nz/#!NPZWnLIa!5ZAHEoTKh...XrS78YOtECMl-4
                    Hi ,

                    i am really not sure if you can restore it , can u make the IDB Tests under "AdvancedFunction" ???

                    greetings / gefattern

                    Comment


                    • #11
                      Originally posted by gefattern View Post

                      Hi ,

                      i am really not sure if you can restore it , can u make the IDB Tests under "AdvancedFunction" ???

                      greetings / gefattern

                      What I have noticed is that even pressing the internal pin on the AV input when i connect the usb otg cable or not I have the same message on the android tool "Found one MASKROM Device".

                      Comment


                      • #12
                        Guys! Problem solved!
                        It was only the wrong ROM.

                        I use the: LeelboxRK-8703-7.1nv3-kodi-1225 .img
                        Link: https://mega.nz/#!wrwyXYxD!0q0yVDFfT...FRiFYl_mUkVbTE

                        This rom isn't native from my box, but runs flawless! Upgrade succeed, thank you guys!
                        Last edited by lucasgabiatti; 03-08-2018, 05:13.

                        Comment


                        • #13
                          lucasgabiatti, tenho o mesmo aparelho com o mesmo problema 'Prepare o BID Fail' alguma outra ROM sugerida? Obrigado.

                          Comment

                          Working...
                          X