Announcement

Collapse
No announcement yet.

Put MA8-4K into download mode (RK3229)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Put MA8-4K into download mode (RK3229)

    Hi all,

    I got a dirty cheap android box from gearbest with RK3229 inside and I want to put some other firmware on it, other than the stock one

    Unfortunately I cannot get it into bootloader (download mode)
    This is what I do:

    1) Disconnect everything
    2) Press the Reset button in AV slot and keep it pressed
    3) Connect a cable in the USB (cable preconnected to PC) and release the reset button after 2 sec.

    Unfortunately the RockchipAndroid tool and the PC does not detect any external device. The drivers are of course preinstalled.

    Any ideas how to get the thing in download mode? What am I doing wrong? I tried also connecting the power supply, but with the same result - for a couple of seconds (maybe 10 s ) nothing happens and then the power LED lits up. But still no detection from PC.

    The device is otherwise working fine, but with the stock ROM.

    Thank you in advance!!!

  • #2
    Try different USB ports on your PC and make sure that you are using the correct USB port on the box too, as just one will likely be geared for flashing.

    There are a few RK3229 flashing videos on Youtube too, which will give you more of an idea.
    MXIII-G II, Chuwi Hibox, Nvidia Shield, NUC6CAYH

    Comment


    • #3
      Hi tpp ,

      what Windows do u use , did you look into the Devicemanager when you connect it ,

      any yellow ? to see . With Win10 , Drivers can make Problems .

      What is RockchipAndroidTool never heard , you need Batchtool 1.7 or 1.8 and the

      Androidtool 2.35 .

      Androidtool 2.35 & DriverAssistant 4.5 here :

      https://m.mediafire.com/folder/2x89d...Rockchip_Tools

      Batchtool please use big G . Thanks .

      greetings / gefattern

      Comment


      • #4
        Hello,

        first thank you for the replies. I watched the videos on YouTube. Also tried the other port (the device has 2). I also ment the Androidtool and yes I have 2.35 and also 4.5 Driver Assistant.

        I run Win 10. The problem is that after connecting as described above the device manager does not show any new device at all. I tried also with another cable. Same result.

        I opened the device and i saw that there is a place for a 3rd usb on the pcb but it is not used.

        Someone else posted that the device is the same as the V88 so there must be a way to flash.

        Any ideas?

        Gesendet von meinem SM-G930F mit Tapatalk

        Comment


        • #5
          Hi tpp ,

          does the Device shows the Storage if you connect the Box as MTP ???

          Has the Box a third not used USB Port or only a Place for solder a third one ???

          Please try this :

          http://chinagadgetsreviews.blogspot....p-rockusb.html

          sometimes Win10 makes problems with RKDrivers , good luck and report /gefattern

          Comment


          • #6
            Thank you for the reply!

            The box has a third one that is not soldiered so it is only a place

            Will try the link and report how it went and also see about mtp.

            Gesendet von meinem SM-G930F mit Tapatalk


            Comment


            • #7
              So I got some kind of a solution for my problem. When i pressed the reset button and connected power it took me to recovery. I saw that because i got a screen connected to the box. From there I chose reboot to bootloader and then after connecting to on one of the usbs worked. Not a perfect solution but a working one

              Gesendet von meinem SM-G930F mit Tapatalk

              Comment


              • #8
                The amount of time that you hold the reset button in will determine whether you go to bootloader or recovery.

                Bootloader should only mean a second or so.
                MXIII-G II, Chuwi Hibox, Nvidia Shield, NUC6CAYH

                Comment


                • #9
                  Hi tpp ,

                  nice to hear , that you got your Box running ,

                  good luck / gefattern

                  Comment


                  • #10
                    Thank you for the support! I tried as advised to use different timings when pressing abd holding the reset button but was not able to access bootloader in that way.

                    Still not a big deal.

                    One more question through - is there a working TWRP Recovery for the V88 ( MA-4K)?

                    Gesendet von meinem SM-G930F mit Tapatalk

                    Comment


                    • #11
                      Hi ,

                      here TWRP for RK3229 :

                      http://freaktab.com/forum/tv-player-...rk3229-release

                      good luck / gefattern

                      Comment


                      • #12
                        Thank you!

                        Gesendet von meinem SM-G930F mit Tapatalk

                        Comment


                        • #13
                          So, I got hold of it - I is a little bit different:

                          1) Press and hold the reset button
                          2) Connect the Power supply
                          3) Connect the USB cable
                          4) Release the reset button

                          Unit in bootloader

                          Now I will try the TWRP

                          Comment

                          Working...
                          X