Announcement

Collapse
No announcement yet.

MX9 PRO Mini RK3328, Android 7 1/8GB WiFi, Fast Lan

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • MX9 PRO Mini RK3328, Android 7 1/8GB WiFi, Fast Lan


    Click image for larger version

Name:	20170419105428_11310.jpg
Views:	1
Size:	167.5 KB
ID:	642278
    Model: MX9 PRO Mini
    Type: TV Box
    System: Android 7.1
    Processor: RK3328
    CPU: Cortex A53
    Core: Quad Core
    GPU: Mali-450
    RAM: 1G
    RAM Type: DDR3
    ROM: 8G
    Max. Extended Capacity: 64G
    Decoder Format: H.265,HD MPEG4
    Video format: 4K,H.264,H.265,MPEG-1,MPEG-4,VC-1
    Audio format: AAC,APE,DDP,FLAC,HD,MP3,OGG,WAV,WMA
    Photo Format: BMP,GIF,JPEG,PNG,TIFF
    Support 5.1 Surround Sound Output: No
    5G WiFi: No
    Bluetooth: Unsupport
    Power Supply: Charge Adapter
    Antenna: No
    Camera: Without
    Language: English,Italian,Multi-language
    DVD Support: No
    HDMI Version: 2.0
    Other Functions: 3D Video,DLNA
    External Subtitle Supported: No
    HDMI Function: HDCP
    RJ45 Port Speed: 100M
    System Bit: 64Bit
    WiFi Chip: AM8189
    Power Type: External Power Adapter Mode
    Power Input Vol: 5V
    Product weight: 0.2700 kg
    Package weight: 0.3400 kg
    Product size (L x W x H): 8.20 x 8.20 x 2.00 cm / 3.23 x 3.23 x 0.79 inches
    Package size (L x W x H): 17.30 x 10.00 x 5.00 cm / 6.81 x 3.94 x 1.97 inches
    Package Contents: 1 x TV Box, 1 x HDMI Cable, 1 x Power Adapter, 1 x Remote Control, 1 x English User Manual
    Click image for larger version

Name:	20170419105428_56216.jpg
Views:	1
Size:	230.8 KB
ID:	642279
    Gearbest
    tЯeboЯ
    Please consider
    Donating to Freaktab

  • #2
    Can someone help me to re-Flash this device?

    I got sticked on a Bootloop cause of the SuperSu, installed from the app, it downloaded and hit on normal flash, it success and ask for reboot, then it reboot and stucked on the startup animation

    Reading some places i see u only need to flash from zip on recovery, but on recovery jumps a message: Unable to mount /sdcard

    I already try using a 2Gb SDCARD, formatted on Fat16/Fat32/NTFS, try to put in TF port, using a USB adapter to put the SDcard on USB2, and USB1 too, also i seem only USB1 (USBv3.0) worked with the keyboard, if i plug it on USB2 (USB2.0) the keyboard are not recognized so i plug a USB HUB on USB1 (3.0) and get the keyboard and the SD, but only KB worked and the SD still get the same error when try to mount

    I also downloaded the new firmware whit Android 7.1.2 from here:
    http://chinagadgetsreviews.com/downl...ni-tv-box.html

    But i just cant Mount The memory i only get:

    Supported API: 3
    E:unknown volume for path [/sdcard]

    -- Couldn't mount /sdcard.
    Installation aborted.

    already tried to Wipe Data/Factory and Cache but still on bootloop

    i downloaded Burn_Card_Maker but it gave me an error after formating the sdcard on the PC:

    L(1005)aml_sdc_burn.UBOOT,and bootloader.PARTITION all not in pkg

    So im a little stucked here

    Comment


    • #3
      You need to use a usb male to male cable, as well as Rockchip batch tool thats found on the same site you downloaded firmware. Hold reset (I think it's inside av port) while you plug it into your pc (usb2 port the box). dc cable not needed as it gets the power off the usb port. Select img file and hit restore, that should get your box working again.

      Comment


      • #4
        It didnt work

        I get a USB Male to Male, and try connecting as you say,.... Nothing happens, no Power Led, no signal, no detection, just nothing, i try connecting the Power AC, and get power light but still nothing, try using ADB, but Windows/Linux won't detect, tried under USB1(3.0) and also USB2 (2.0)

        Dosnt look like any of the ports act as miniUSB connectors

        Also try connecting via ADB over lan, but it doesn't seem to had Network ADB

        Using the command ADB connect 192.168.8.8, and no device found (Ip assigned by the router over DHCP), and enable DHCP on the device

        Now send the package you want to apply
        to the device with "adb sideload <filename>"...

        So, in resume, i can't use Rockchip batch tool and Rockchip_DriverAssistant, by the moment

        Attach some pics of the MainBoard

        Comment


        • #5
          I would try another usb male to male cable, the mainboard should normally turn on with just the usb cable plugged in. Try getting a shorter cable if you can.

          Comment


          • #6
            I have the same box.
            USB cable must be connected on port black (usb2).
            You must press reset button, on AV port. Use a toothpick

            Comment


            • #7
              Sorry i didn't write before, i have to wait to the cable to reach

              the box it's finally detected by the system, so i follow the whole procedure:

              1.- turn off the box
              2.- Install Driver Assistant v4.4 [As admin] (NOTElder versions didn't work)
              3.- Open RKBatchTool.exe (v1.8) [As Admin]
              4.- Load firmware "mini_rk3328_d16_8189-6051_20170526_r1(mx9pro mini kodi17.2).img" [Just in case i renamed it to firmware.img to avoid rare characters error, and double check no spaces on route, example: c:\temp\firmware.img]
              5.- Once upon finish loading the img, take the MX9ProMini and press the AV with toothpick and without releasing connected the USB male to male on USB2, to PC USB (It won't be detected if you only connect it and not press AV)
              6.- RKBatchTool.exe it turn on a green button under connected devices
              7.- Press Upgrade, and wait, get following messages, and a final green line all ok:

              **********Restore Action**********
              **********Restore Start Total<1>**********
              <Layer 1-3> Test Device Start
              <Layer 1-3> Test Device Success
              <Layer 1-3> Lowerformat Device Start
              <Layer 1-3> Lowerformat Device Success
              <Layer 1-3> Test Device Start
              <Layer 1-3> Test Device Success
              <Layer 1-3> Check Chip Start
              <Layer 1-3> Check Chip Success
              <Layer 1-3> Get FlashInfo Start
              <Layer 1-3> Get FlashInfo Success
              <Layer 1-3> Prepare IDB Start
              <Layer 1-3> Prepare IDB Success
              <Layer 1-3> Download IDB Start
              <Layer 1-3> Download IDB Success
              <Layer 1-3> Reset Device Start
              <Layer 1-3> Reset Device Success
              <Layer 1-3> Wait For Loader Start
              <Layer 1-3> Wait For Loader Success
              <Layer 1-3> Test Device Start
              <Layer 1-3> Test Device Success
              <Layer 1-3> Download Firmware Start
              <Layer 1-3> Download Firmware Success
              <Layer 1-3> Reset Device Start
              <Layer 1-3> Reset Device Success
              **********Restore Done Success<1> Fail<0> Time<163703>ms**********

              8.- exit the program, disconnect USB and then connect to the TV and 5v power, and leave it

              But i get no screen, wait another 10 minutes, and nothing happens, it keeps only with the red light, NO BLUE LIGHT, and no image. so i decided to start over, but this time press restore, same result

              And i can't get the recovery either

              I downloaded the firmware again but get the same result, so what im doing wrong

              Comment


              • #8
                Try using Android tool, here's the latest version https://mega.nz/#!xbZWSQQB!5DmuL3C06...pUTZawPmOZD1pw . To flash firmware Upgrade Firmware > Firmware > Select img file > Erase Flash > Upgrade.

                Comment


                • #9
                  Finally its solved, i post the weird solution

                  So the solution were only on the way the connectors are plugged

                  During the update, i keep the HDMI connected and when it finish only connect the 5v power, and it keeps only on red light and no control or keyboard respond

                  The weird solution resides on plug the HDMI cable after the 5v, and like magic it works

                  this thing drives me crazy all day but it's finally working

                  So, after any firmware update you should disconnect all cables and when connecting back to a TV first plug 5v cable and about 3-5 seconds later the HDMI and Vuala, blue light turns on and the device start working after a few minutes, if you put on the HDMI first it will keeps on red light blocked, and using the control or keyboard don't wake up the device, don't know why but it solves all the troubles, at least on first boot, after the first boot you can leave the HDMI first and then the Power, this looks like an issue of only the first boot

                  Comment


                  • #10
                    Originally posted by steev_666 View Post
                    Finally its solved, i post the weird solution

                    So the solution were only on the way the connectors are plugged

                    During the update, i keep the HDMI connected and when it finish only connect the 5v power, and it keeps only on red light and no control or keyboard respond

                    The weird solution resides on plug the HDMI cable after the 5v, and like magic it works

                    this thing drives me crazy all day but it's finally working

                    So, after any firmware update you should disconnect all cables and when connecting back to a TV first plug 5v cable and about 3-5 seconds later the HDMI and Vuala, blue light turns on and the device start working after a few minutes, if you put on the HDMI first it will keeps on red light blocked, and using the control or keyboard don't wake up the device, don't know why but it solves all the troubles, at least on first boot, after the first boot you can leave the HDMI first and then the Power, this looks like an issue of only the first boot
                    Sounds like a glitchy bootloader, might be fixed with future updates (wouldn't hold my breath) these boxes are cheap for a reason....

                    Comment


                    • #11
                      Got this box yesterday (not the mini version). Ran SuperSU. Bricked the box - just like the other guy. Then spent most of yesterday trying to re-flash a ROM using the Rockchip Batch Tool (you need to use the microUSB connector on the box, and the reset hole is red, on the underside). Each ROM I tried was very temperamental and generally excludes bluetooth. Tried using the SDCard method, didn't work. Tried RK Android Tool, same buggy ROM installation. Now trying a different, high quality USB lead. Absolute nightmare. I just want the stock ROM and I want it to work. Also, can anyone get Amazon Prime Video to actually play videos without crashing?
                      Last edited by Archibald Simpson; 10-13-2017, 11:13.

                      Comment

                      Working...
                      X