Announcement

Collapse
No announcement yet.

Help to unbrick MX9 Pro

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Help to unbrick MX9 Pro

    Hello,
    Box have no sign of life, no lights, no signal on tv, computer doesn't see it (power adapter is ok).
    I want to try to put it in MASKROM mode and flash the firmware with RK Batch Tool.
    I know that I have to short pins on the eMMC chip, but on this Toshiba chip (THGBMBG7D2KBAIL) pins are not visible.
    How can I get in to MASKROM mode?
    Thanks.

  • #2
    Originally posted by Nebojsa View Post
    Hello,
    Box have no sign of life, no lights, no signal on tv, computer doesn't see it (power adapter is ok).
    I want to try to put it in MASKROM mode and flash the firmware with RK Batch Tool.
    I know that I have to short pins on the eMMC chip, but on this Toshiba chip (THGBMBG7D2KBAIL) pins are not visible.
    How can I get in to MASKROM mode?
    Thanks.
    Hi ,

    maybe it is possible to short the pins on the back (middle)(two golden plates) ,

    i know that another User successfully restored his Box this Way , but i can give

    no Guarantee , you must know if u try .

    good luck / gefattern

    Comment


    • #3
      Thanks for your response.
      I tried that already, but no luck.
      Tried with all golden plates I can find, back and front.
      Maybe must push reset button too.
      Is this user who successfully restored his box have the same box as me?
      Can you show me at the picture exactly which golden points he shorted?
      Thanks.

      Comment


      • #4
        hi,
        try to shortcut the 2 pins.



        Click image for larger version

Name:	Nand rear.jpg
Views:	1
Size:	119.0 KB
ID:	693586

        Comment


        • #5
          Hi ,

          please try the way "manu manu4" discribed and please report the Results , to help other

          Users out of there Brick . good luck / gefattern

          Comment


          • #6
            Hi,
            ​​​I tried that but no luck.

            what I tried:

            short and connect with PC to USB 1
            short and connect with PC to USB 2
            short and connect with PC to OTG (micro USB)

            All that again but with pressed reset button

            All that again but with pressed power button

            All that again but with pressed power and reset button

            And all that again but with connected power adapter

            Nothing works, the box is not recognized by PC at all.

            ​​​​​What else can I try?

            Comment


            • #7
              Make sure your plugging your usb to a 2.0 port or try another pc

              Comment


              • #8
                Originally posted by Nebojsa View Post
                Hello,
                Box have no sign of life, no lights, no signal on tv, computer doesn't see it (power adapter is ok).
                I want to try to put it in MASKROM mode and flash the firmware with RK Batch Tool.
                I know that I have to short pins on the eMMC chip, but on this Toshiba chip (THGBMBG7D2KBAIL) pins are not visible.
                How can I get in to MASKROM mode?
                Thanks.
                Hi ,

                try the two golden plates on the top side of Picture 3 , right below the Nand , otherwise you can try the

                very small contacts on the Nand self , to see on Picture 3 , too , 4 on both sides .

                good luck / gefattern

                Comment


                • #9
                  Originally posted by Chriztoph3r View Post
                  Make sure your plugging your usb to a 2.0 port or try another pc
                  I tried on 3 different PCs, they do not have USB 3.0, just 2.0. But, now I see that the cable I use, USB male to male, is USB 3.0 (with blue plastic). I do not have another cable. Is that may be a problem?

                  Comment


                  • #10
                    Originally posted by gefattern View Post

                    Hi ,

                    try the two golden plates on the top side of Picture 3 , right below the Nand , otherwise you can try the

                    very small contacts on the Nand self , to see on Picture 3 , too , 4 on both sides .

                    good luck / gefattern
                    Yes, I tried those two golden plates, not working.
                    Tried those small contact on nand too, 4 pairs, 2 on each side, not working either.

                    Comment


                    • #11
                      Originally posted by Nebojsa View Post

                      Yes, I tried those two golden plates, not working.
                      Tried those small contact on nand too, 4 pairs, 2 on each side, not working either.
                      Hi ,

                      a shame that a restore is made so complicated , not sure how to get it in MRM , if this not

                      works , but somewhere here i read , that a Guy was able to connect after he shorted 2 pins

                      of the USB Port , but how and which pins i do not know .

                      hope you can get it / good luck / gefattern

                      Comment


                      • #12
                        Yes, I found something about that here:

                        https://pakfones.com/how-to-repair-d...ndroid-phones/

                        will try that too.

                        Comment


                        • #13
                          Finally, I've ressurected my MX9 Pro from "red light only" state, tried again those two pins shown above to enter MASKROM, but with this procedure:

                          1. open Rockchip Batch Tool and import firmware
                          2. short two golden points under NAND chip and keep it shorted (shown in manu_manu4 post)
                          3. plug the micro USB cable into OGT port
                          4. windows should make "add device" sound and device should appear in Batch Tool
                          5. unshort golden pins
                          6. press Upgrade to start flashing

                          After this procedure the device started as it should and now is working fine

                          Comment


                          • #14
                            I'm glad that you make it working again.
                            Do you have the same board as mine?
                            Did you use power adapter as well?
                            I do not have red light, no light at all.
                            This procedure didn't work for me, maybe I have hardware failure...

                            Comment


                            • #15
                              it was without power supply, just USB cable and piece of cable to short the pins. If you've got no light at all, it might be broken for good. It should power itself even from USB ports, did you try to connect it to computer and nothing happened? I have 4/32GB version.

                              Comment

                              Working...
                              X